<!DOCTYPE html>
<html lang="en">
<head>
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=no" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
<title>Memory Systems for AI: Part 4</title>
<meta http-equiv="Cache-Control" content="no-cache"/>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<link rel="shortcut icon" href="//static.designandreuse.com/IMAGES/favicon.ico" />
<link rel="alternate" type="application/rss+xml" title="All D and R Feeds" href="https://www.design-reuse.com/xml/1/1/all/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Headline News" href="https://www.design-reuse.com/xml/1/1/news/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Industry Articles" href="https://www.design-reuse.com/xml/1/1/articles/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R New Products" href="https://www.design-reuse.com/xml/1/1/products/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Wanted IPs" href="https://www.design-reuse.com/xml/1/1/wanted/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Industry Expert Blogs" href="https://www.design-reuse.com/xml/1/1/blogs/rss.xml"/>
<meta name="description" content=" In part three of this series, we discussed how a Roofline model can help system designers better understand if the performance of applications running ..."/>
<meta name="keywords" content="memory systems for ai: part 4, rambus blog, steven woo, rambus"/>
	<meta property="og:type" content="article"/>
			<meta property="og:image" content="https://www.design-reuse.com/industryexpertblogs/images/rambus.gif"/>
			<meta property="og:title" content="Memory Systems for AI: Part 4"/>
			<meta property="og:url" content="https://www.design-reuse.com/industryexpertblogs/47679/memory-systems-for-ai-part-4.html"/>
			<meta property="og:description" content=" In part three of this series, we discussed how a Roofline model can help system designers better understand if the performance of applications running ..."/>
		
	<meta property="og:site_name" content="Design And Reuse"/>
<!--sphider_noindex--> 
<meta http-equiv="Pragma" content="no-cache"/>
<meta name="Expires" content="Fri, 01 Jan 1990 00:00:00 GMT"/>
<meta name="Created" content="2020-03-12 15:41:00"/><!--[if lte IE 8]>
<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>

<script src="https://www.design-reuse.com//jscript/respond.min.js"></script>
<![endif]-->
	<link rel="stylesheet" type="text/css" href="https://static.designandreuse.com/staticnews-20181116.css"/>

</head>
<body>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-118253-2', 'auto');
  ga('send', 'pageview');

</script>
<form>
<input id="menu-toggle" class="menu-toggle" type="checkbox">
<nav>
	<div class="menu">
	<ul>
		<li><a href="https://www.design-reuse.com/">Home</a></li>
		<li><a href="https://www.design-reuse.com/sip/">Search Silicon IP</a></li>
		<li><a href="https://www.design-reuse.com/vip/">Search Verification IP</a></li>
		<li><a href="https://www.design-reuse.com/news/">Latest News</a></li>
		<li><a href="https://www.design-reuse.com/articles/">Industry Articles</a></li>
		<li><a href="https://www.design-reuse.com/industryexpertblogs/">Industry Expert Blogs</a></li>
		<li><a href="https://www.design-reuse.com/video/">Videos</a></li>
		<li><a href="https://www.design-reuse.com/slides/">Slides</a></li>
		<li><a href="https://www.design-reuse.com/ipsoc2018/">Events</a></li>
 
	</ul>
  </div> 
</nav>
<section id="contentfull">
<div class="top-bar">
  <label for="menu-toggle" id="toggle">&equiv; <span>Menu</span></label> 
  
  <a id="drlogoS" href="https://www.design-reuse.com/">Design And Reuse</a>

<ul id="top-bar-subscribe" style="margin-right:15px; margin-top:5px">

			<li class="d-inline" >
		<a class="login c7 sz11" href="https://www.design-reuse.com/login2.php?nexturl=https%3A%2F%2Fwww.design-reuse.com%2Findustryexpertblogs%2F47679%2Fmemory-systems-for-ai-part-4.html%3Futm_medium%3Drss%26utm_source%3Ddesignreuse%26utm_content%3D1%26utm_campaign%3D47679">Login</a>
		</li>
		<li class="c5 sz11 d-inline">|</li>
		

	<li id="nav-login167156" class="d-inline">
	<a class="login c7 sz11" href="https://www.design-reuse.com/users/signup.php">Subscribe</a>
	</li>


</ul>
  </div> 
</form>
<div id="bandeau-nav167156">
<div class="list grid-980">

<ul id="nav-right167156" class="nav-right">


<li class="d-inline">
<a class="c7 sz11" href="https://www.design-reuse.com/about/">Company</a>
</li>
<li class="c5 sz11 d-inline">|</li>

<li class="d-inline">
<a class="c7 sz11" href="https://www.design-reuse.com/foundry/siliconip/cn.php">D&amp;R China</a>
</li>
<li class="c5 sz11 d-inline">|</li>
<li class="d-inline">
<a class="c7 sz11" href="https://www.design-reuse.com/foundry/siliconip/drembedded3.php" rel="nofollow">dr-embedded.com</a>
</li>

<li class="c5 sz11 d-inline">|</li>
<li class="d-inline">
<a class="c7 sz11" href="http://www.design-reuse-enterprise.com/" rel="nofollow">D&amp;R Products</a>
</li>
<li class="c5 sz11 d-inline">|</li>
 
<li class="d-inline dropdown">
<span class="c7 sz11" ><img src="https://static.designandreuse.com/img16/cn.png" width="21" height="16" style="margin-top:4px; margin-right:10px"></span>
  <div class="dropdown-content">
    <a href="https://www.design-reuse.com/" class="c5 sz11 d-inline"> <img src="https://static.designandreuse.com/img16/en.png" width="16" height="12" style="margin-top:4px;"> English</a>
    <a href="https://www.design-reuse.com/foundry/siliconip/cn.php" class="c5 sz11 d-inline"><img src="https://static.designandreuse.com/img16/cn.png" width="16" height="12" style="margin-top:4px"> Chinese</a>
  </div>
</li>

 
<style>
.dropdown {
    position: relative;
    display: inline-block;
	cursor: pointer;
}

.dropdown-content {
    display: none;
    position: absolute;
    background-color: white;
    min-width: 80px;
    box-shadow: 0px 8px 16px 0px rgba(0,0,0,0.2);
    padding: 2px;
	z-index: 99999;
	margin-top: -8px;
}

.dropdown:hover .dropdown-content {
    display: block;
}

.dropdown-content a {
    color: black;
    padding: 1px;
    text-decoration: none;
    display: block;
}
.dropdown-content a:hover {background-color: #f1f1f1}
</style>
			<li class="d-inline" >
		<a class="login c7 sz11" href="https://www.design-reuse.com/login2.php?nexturl=https%3A%2F%2Fwww.design-reuse.com%2Findustryexpertblogs%2F47679%2Fmemory-systems-for-ai-part-4.html%3Futm_medium%3Drss%26utm_source%3Ddesignreuse%26utm_content%3D1%26utm_campaign%3D47679">Login</a>
		</li>
		<li class="c5 sz11 d-inline">|</li>
		

	<li id="nav-login167156" class="d-inline">
	<a class="login c7 sz11" href="https://www.design-reuse.com/users/signup.php">Subscribe to D&amp;R SoC News Alert</a>
	</li>


</ul>
</div>
</div>
<div id="leadeboard"><div id="leadeboard-in" >
	<a href="https://www.design-reuse.com/" id="drlogo">Design And Reuse</a>
	
</div></div> 
<div id="center">
    <div class="outter"></div>
    <div id="mainmenu" class="navigation navigation2012">
        <ul id="menu-bar">
            <li id="nav_onglet_1" class=" actu">
                <a href="https://www.design-reuse.com/sip/" class="imaged"><span class="text">Search IP</span><span class="drop"></span></a>
				<ul class="ombrage">
				
                    <li class="first">
					     <span>Categories</span>
                        <div class="ul">
                            <ul>
                                <li class="first"><a href="https://www.design-reuse.com/sip/"><strong>Silicon IP</strong></a></li>
                                <li><a href="https://www.design-reuse.com/sip/analog-mixed-signal-c-3/">Analog & Mixed Signal</a></li>
                                <li><a href="https://www.design-reuse.com/sip/storage-controller-phy-c-5/">Storage Controller &amp; PHY</a></li>
                                <li><a href="https://www.design-reuse.com/sip/graphic-peripheral-c-6/">Graphic &amp; Peripheral</a></li>
                                <li><a href="https://www.design-reuse.com/sip/interfaces-c-7/">Interface Controller &amp; PHY</a></li>
                                <li><a href="https://www.design-reuse.com/sip/processors-microcontrollers-c-9/">Processors &amp; Microcontrollers</a></li>
                                <li><a href="https://www.design-reuse.com/sip/memory-logic-library-c-10/">Memory &amp; Logic Library</a></li>
                                <li><a href="https://www.design-reuse.com/sip/security-c-11/">Security</a></li>
                                <li><a href="https://www.design-reuse.com/sip/multimedia-c-12/">Multimedia</a></li>
                                <li><a href="https://www.design-reuse.com/sip/wireline-communication-c-13/">Wireline Communication</a></li>
                                <li><a href="https://www.design-reuse.com/sip/wireless-communication-c-14/">Wireless Communication</a></li>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/sip/provider.php"><strong>Silicon IP Vendors</strong></a>
                                </li>



								
                            </ul>
                        </div>
                    </li>

					
                   <li>
						<span>&nbsp;</span>

                        <div class="ul">
							<ul>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/vip/"><strong>Verification IP</strong></a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/vip/">Search / Browse</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/vip/provider.php">Verification IP Vendors</a>
                                </li>

	
					
									<li class="first">
                                    <a href="https://www.design-reuse.com/hds/"><strong>Software IP</strong></a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/hds/">Search / Browse</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/hds/provider.php">Software IP Vendors</a>
                                </li>
   	  		
                         
                                <li>
                                    <strong>&nbsp;</strong>
                                </li>
                                <li style="border-top:0px">
                                    <strong>&nbsp;</strong>
                                </li>
                                <li>
                                    <strong>Additional Services</strong>
                                </li>
													
	                                <li>
                                    <a href="https://www.design-reuse.com/sip/wanted/">Wanted IPs</a>
                                </li>
   	  	
                                <li>
                                    <a href="https://www.design-reuse.com/ipanalytics/">IP Analytics</a>
                                </li>
                            </ul>
                        </div>
                    </li>
					
					<li>
						<a href="https://www.design-reuse.com/sip/">	
						Featured Products</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="https://www.design-reuse.com/sip/unipro-ip-core-ip-26999/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/hdl.gif" alt="HDL Design House" height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/unipro-ip-core-ip-26999/">UniPro IP Core</a></p></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/sip/10-bit-high-speed-video-dac-in-tsmc-65nm-40nm-28nm-ip-46729/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/synopsys.gif" alt="Synopsys, Inc." height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/10-bit-high-speed-video-dac-in-tsmc-65nm-40nm-28nm-ip-46729/">10-bit, High Speed Video DAC in TSMC (65nm, 40nm, 28nm)</a></p></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/sip/remote-controller-receiver-ip-11440/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/xylon.gif" alt="Xylon" height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/remote-controller-receiver-ip-11440/">Remote Controller Receiver</a></p></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/sip/gen2-ddr-multiphy-in-tsmc-28nm-ip-46627/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/synopsys.gif" alt="Synopsys, Inc." height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/gen2-ddr-multiphy-in-tsmc-28nm-ip-46627/">Gen2 DDR multiPHY in TSMC (28nm)</a></p></div></li>	     
						</ul></div>
						
                    </li>

                </ul>
				
            </li>
  		

	
					
	
            <li id="nav_onglet_3" class=" actu">
                <a href="https://www.design-reuse.com/news/" class="imaged"><span class="text">News</span><span class="drop"></span></a>
              <ul>
                    <li class="first">
                        <span>Categories</span>
                        <div class="ul">
                            <ul>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/news/semiconductor-ip-soc-0.html">IP/SoC Products </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/embedded-systems-0.html">Embedded Systems </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/foundries-0.html">Foundries</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/fpga-0.html">FPGA </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/fabless-0.html">Fabless / IDM </a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/deals-0.html">Deals</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/legal-0.html">Legal</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/business-0.html">Business</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/financial-0.html">Financial Results</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/people-0.html">People</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/commentary-analysis-0.html">Commentary / Analysis</a>
                                </li> 
								<li>
                                    <a href="https://www.design-reuse.com/news/mostpopular"><strong>20 Most Popular News</strong></a>
                                </li>
                            </ul>
                        </div>
                    </li>
					<li>
                        <a href="https://www.design-reuse.com/news/">					
						Latest News</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="//www.design-reuse.com/news/47675/quicklogic-efpga-globalfoundries-22fdx.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news47675/quicklogic.jpg"  alt="quicklogic-efpga-globalfoundries-22fdx" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="//www.design-reuse.com/news/47675/quicklogic-efpga-globalfoundries-22fdx.html">QuickLogic's eFPGA Qualified on GLOBALFOUNDRIES 22FDX Platform for IoT and Edge AI Applications</a></p><div class="meta">Thursday Mar. 12, 2020</div></div></li>	<li><div class="media"><a href="//www.design-reuse.com/news/47674/cadence-tensilica-hifi-ip-tensorflow-lite-microcontrollers.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news47674/cadence.jpg"  alt="cadence-tensilica-hifi-ip-tensorflow-lite-microcontrollers" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="//www.design-reuse.com/news/47674/cadence-tensilica-hifi-ip-tensorflow-lite-microcontrollers.html">Cadence Tensilica HiFi IP Accelerates AI Deployment with Support for TensorFlow Lite for Microcontrollers</a></p><div class="meta">Thursday Mar. 12, 2020</div></div></li>	<li><div class="media"><a href="//www.design-reuse.com/news/47671/black-swan-event-2020-ic-market-forecast-revision.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news47671/swan.jpg"  alt="black-swan-event-2020-ic-market-forecast-revision" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="//www.design-reuse.com/news/47671/black-swan-event-2020-ic-market-forecast-revision.html">&quot;Black Swan&quot; Event Triggers Revision to 2020 IC Market Forecast</a></p><div class="meta">Wednesday Mar. 11, 2020</div></div></li>	     
						</ul></div>

						
                    </li>
                </ul>

            </li>
            <li id="nav_onglet_4" class=" actu">
                <a href="https://www.design-reuse.com/articles/" class="imaged"><span class="text">Industry Articles</span><span class="drop"></span></a>
              <ul>
                    <li class="first">
                        <span>Categories</span>
                        <div class="ul">
                            <ul>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/articles/semiconductor-ip-soc-0.html">IP/SoC Products </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/articles/embedded-systems-0.html">Embedded Systems </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/articles/foundries-0.html">Foundries</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/articles/fpga-0.html">FPGA </a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/articles/business-0.html">Business</a>
                                </li>
								<li>
                                    <a href="https://www.design-reuse.com/articles/mostpopular"><strong>20 Most Popular Articles</strong></a>
                                </li>
                            </ul>
                        </div>
                    </li>
					<li>
                        <a href="https://www.design-reuse.com/articles/">					
						Featured Articles</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="https://www.design-reuse.com/articles/47680/improving-performance-and-security-in-iot-wearables.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news47680/iot2.jpg"  alt="improving-performance-and-security-in-iot-wearables" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/articles/47680/improving-performance-and-security-in-iot-wearables.html">Improving performance and security in IoT wearables</a></p><div class="meta">Thursday Mar. 12, 2020</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/articles/47623/testing-embedded-mram-ip-for-socs.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news47623/syno.jpg"  alt="testing-embedded-mram-ip-for-socs" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/articles/47623/testing-embedded-mram-ip-for-socs.html">Testing Embedded MRAM IP for SoCs</a></p><div class="meta">Monday Mar. 02, 2020</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/articles/47556/sram-puf-is-increasingly-vulnerable.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news47556/puf2.jpg"  alt="sram-puf-is-increasingly-vulnerable" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/articles/47556/sram-puf-is-increasingly-vulnerable.html">SRAM PUF is Increasingly Vulnerable</a></p><div class="meta">Wednesday Feb. 19, 2020</div></div></li>	     
						</ul></div>

						
                    </li>
                </ul> 
            </li>
            <li id="nav_onglet_5" class=" actu">
                <a href="https://www.design-reuse.com/industryexpertblogs/" class="imaged"><span class="text">Blogs</span><span class="drop"></span></a>
               <ul>
 					<li>
                        <a href="https://www.design-reuse.com/industryexpertblogs/">					
						Industry Expert Blogs</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="https://www.design-reuse.com/industryexpertblogs/47679/memory-systems-for-ai-part-4.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/industryexpertblogs/images/rambus.gif"  alt="memory-systems-for-ai-part-4" width="64" height="64" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/industryexpertblogs/47679/memory-systems-for-ai-part-4.html">Memory Systems for AI: Part 4</a></p><div class="meta">Rambus Blog - Steven Woo, Rambus</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/industryexpertblogs/47678/ddr5-off-and-running.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/industryexpertblogs/images/vipexperts.jpg?2"  alt="ddr5-off-and-running" width="64" height="64" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/industryexpertblogs/47678/ddr5-off-and-running.html">DDR5 - Off and Running</a></p><div class="meta">VIP Experts Blog - Synopsys</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/industryexpertblogs/47672/risc-v-processor-trace.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/industryexpertblogs/images/ultrasoc.jpg"  alt="risc-v-processor-trace" width="64" height="64" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/industryexpertblogs/47672/risc-v-processor-trace.html">RISC-V processor trace now standardized: Even open source needs agreed specs</a></p><div class="meta">UltraSoC  Blog - Gadge Panesar, UltraSoC</div></div></li>	     
						</ul></div>

						
                    </li>
                </ul>     
            </li>
            <li id="nav_onglet_6" class=" cols">
                <a href="https://www.design-reuse.com/video/" class="imaged nodrop"><span class="text">Videos</span></a>

            </li>
            <li id="nav_onglet_8" class=" cols">
                <a href="https://www.design-reuse.com/slides/" class="imaged nodrop"><span class="text">Slides</span></a>

            </li>

            <li id="nav_onglet_7" class=" cols">

					<a  rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2020/" class="imaged"><span class="text">Events</span><span class="drop"></span></a>
					<ul>
                    <li class="first">
					
					  <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2020/">IP-SOC  2020</a>

					<!--<span>Archives</span>-->
                        <div class="ul">
                            <ul>

								<li class="first">
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2019/">IP-SoC Days 2019</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2018/">IP-SoC Days 2018</a>
                                </li>
								<li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/">IP-SoC Days 2017</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2019/grenoble2019/">IP-SoC 2019</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2018/grenoble2018/program.jsp">IP-SoC 2018</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsoc2017/postEvent.jsp">IP-SoC 2017</a>
                                </li>
                          


                            </ul>
                        </div>
                    </li>

                </ul>
            </li>
 
        </ul>
		
<div id="search">
		<form method="get" action="https://www.design-reuse.com/search/"  style="top:0px; width:250px">
<ul id="searchFilter"><li class="filterBtn" onclick="return true" title="search filter">
<div class="searchDropdown">
<fieldset>
<legend>Choose a filter </legend>
<ul id="searchOptions">
<li><input id="areafull" type="radio" value="full" checked="checked" name="area"/><label for="areafull">Full Site Search</label></li>
<li><input id="areasip" type="radio" value="sip" name="area"/><label for="areasip">Silicon IP</label></li>
<li><input id="areavip" type="radio" value="vip" name="area"/><label for="areavip">Verification IP</label></li>
<li><input id="areahds" type="radio" value="hds" name="area"/><label for="areahds">Software IP</label></li>
<li><input id="areanews" type="radio" value="news" name="area"/><label for="areanews">News</label></li>
<li><input id="areaarticle" type="radio" value="articles" name="area"/><label for="areaarticle">Industry Articles</label></li>
</ul>
</fieldset>
</div>
</li>
</ul>
<input id="i" name="i" class="inset " type="text" maxlength="255" value="Search D&amp;R site"/>
<input class="magBtn" type="submit" value="Search D&amp;R site" title="search"/>
</form></div>

    </div>
</div>


<div id="section">
<div id="global">


<!--/sphider_noindex--> 

<div id="content">
 

<div id="left800">








<h1>
Industry Expert Blogs</font></h1>
<br/>






<table><tr valign="top">
<td>
	<img src="/industryexpertblogs/images/rambus.gif" border="0" width="64" height="64" alt="Rambus Blog" style="margin-right:15px"/>

</td>
<td>

	<h2  style="margin-bottom:0px; padding-bottom:0px; margin-top:0px; padding-top:0px">
	Memory Systems for AI: Part 4	</h2>
	
	
				<a href="/exit/?urlid=29754">
			
	Rambus Blog		</a> 
		
		- 
		Steven Woo, Rambus <br/>
	Mar. 12, 2020 <br/>
	

</td>
</tr>
</table>




<div id="wrapleft500">
<div id="left500" class="bluelink">


<p> In part three of this series, we discussed how a Roofline model can help system designers better understand if the performance of applications running on specific processors is limited more by compute resources, or by memory bandwidth. Rooflines are particularly useful when analyzing machine learning applications like neural networks running on artificial intelligence (AI) processors. In this blog post, we&#x2019;ll be taking a closer look at a Roofline model that illustrates how AI applications perform on Google&#x2019;s tensor processing unit (TPU), NVIDIA&#x2019;s K80 GPU and Intel&#x2019;s Haswell CPU.</p>  <p>The graph above is featured in a paper published by Google a couple of years ago detailing the first-generation Tensor Processing Unit (TPU). It&#x2019;s a very insightful paper, because it compares the performance of Google&#x2019;s TPU against two other processors. You can see three different Rooflines in the graph above: one in red, one in gold and one in blue. The blue Roofline represents the Google TPU, a special purpose-built piece of silicon that was specifically designed for AI inferencing. The NVIDIA K80 &#x2013; a GPU designed to handle a larger class of operations &#x2013; is in red. Represented in gold is the Roofline for the Intel Haswell CPU, a very general-purpose processor.</p><p><a href="https://www.design-reuse.com/exit/?urlid=38987" >Click here to read more ...</a><br/><br/></p><!--sphider_noindex--> 















<style>
		table#contactprov, table#contactprov td
		{
		padding:0px!important;
		border-collapse:collapse!important; 
		border:1px solid black;
		}
		table.hidden, table.hidden td
		{
		padding:0px!important;
		border-collapse:collapse!important; 
		border:0!important;
		}
	
		</style>


<br/><br/>  


    





<script type="text/javascript">
//<!--	
	
			
	function GoOutside(url) {
		newsid = 47679 ;
		location.href = "//www.design-reuse.com/industryexpertblogs" + "/exit/?id=" + newsid  + "&url=" + url;
		return false;
	}
	

			
//-->
</script>

<!--/sphider_noindex-->


</div>
</div>





	<!--sphider_noindex--> 
	<div id="middle300">

	<div style="margin-top: 15px;"> 

<ul class="share-buttons">
  <li><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.design-reuse.com%2Findustryexpertblogs%2F47679%2Fmemory-systems-for-ai-part-4.html&t=Memory+Systems+for+AI%3A+Part+4" title="Share on Facebook" target="_blank"><img src="//static.designandreuse.com/img16/facebook.png"></a></li>
  <li><a href="https://twitter.com/intent/tweet?source=https%3A%2F%2Fwww.design-reuse.com%2Findustryexpertblogs%2F47679%2Fmemory-systems-for-ai-part-4.html&text=Memory+Systems+for+AI%3A+Part+4:%20https%3A%2F%2Fwww.design-reuse.com%2Findustryexpertblogs%2F47679%2Fmemory-systems-for-ai-part-4.html&via=designreuse" target="_blank" title="Tweet"><img src="//static.designandreuse.com/img16/twitter.png"></a></li>
  <li><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.design-reuse.com%2Findustryexpertblogs%2F47679%2Fmemory-systems-for-ai-part-4.html" target="_blank" title="Share on Google+"><img src="//static.designandreuse.com/img16/google.png"></a></li>
  <li><a href="http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.design-reuse.com%2Findustryexpertblogs%2F47679%2Fmemory-systems-for-ai-part-4.html&title=Memory+Systems+for+AI%3A+Part+4&source=%2F%2Fwww.design-reuse.com%2F" target="_blank" title="Share on LinkedIn"><img src="//static.designandreuse.com/img16/linkedin.png"></a></li>
</ul>
 <br/></div>

	 
		<div class="gradient">
		<h3 class="oswald" style="margin-bottom: 15px;"><a href="http://www.design-reuse.com/sip/"  style="color:#E41129;" >Search Silicon IP</a></h3>
		<div class="type1 bluelink">
		<div style="font-size: 12px; color:black;">12,000 IP Cores from 400 Vendors</div>
		<form method="get" action="http://www.design-reuse.com/sip/" name="formsip"  style="padding:6px">
		<input class="searchip-text" type="text" id="qsip" name="q"  onblur="if (this.value == '') {this.value = 'Enter Keywords....';}" onfocus="if(this.value == 'Enter Keywords....') {this.value = '';}" value="Enter Keywords...." style="float: left;"/>
		<input type="submit" class="searchip" alt="Search Design-Reuse.com"/>
		</form>
					<div style="color:black; font-weight: bold; font-size: 11px;">Example: <a class="ipexample" href="//www.design-reuse.com/sip/?q=rambus">Rambus IP Cores</a></div>
				</div>
		<div class="spaceboy" style="clear:both">&nbsp;</div>
		</div>
	
	

	
	<div class="bloc300 gradient">
			  <h3 class="oswald"  style="margin-bottom: 15px;">Related Blogs</h3>
			 <div> 

	<div class="type1">


	<ul class="arrowList1" style="line-height: 13px; height: auto; border-bottom: 0px">
	

<li><a href="//www.design-reuse.com/industryexpertblogs/47662/memory-systems-for-ai-part-3.html">
Memory Systems for AI: Part 3</a></li>

<li><a href="//www.design-reuse.com/industryexpertblogs/42082/why-how-and-what-of-custom-socs.html">
Why, How and What of Custom SoCs</a></li>

<li><a href="//www.design-reuse.com/industryexpertblogs/47503/obsolete-eol-parts.html">
Obsolete &amp; EOL Parts</a></li>

<li><a href="//www.design-reuse.com/industryexpertblogs/44314/decipher-the-meaning-of-silicon-as-a-service.html">
Decipher the Meaning of Silicon-as-a-Service </a></li>

<li><a href="//www.design-reuse.com/industryexpertblogs/39402/monitoring-chip-age.html">
Let's Talk PVT Monitoring: Understanding Your Chip's Age</a></li>


	</ul>
	</div></div>
	<div class="spaceboy" style="clear:both">&nbsp;</div>
		</div>
	
	
<!--/sphider_noindex-->
	</div>





</div></div>
	<div id="right135">
	<!--sphider_noindex-->
	<ins data-revive-zoneid="5" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
	<br/><br/>
	<ins data-revive-zoneid="6" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
	<br/><br/>
	
<ins data-revive-zoneid="7" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
	<br/><br/>
		<!--/sphider_noindex-->
	</div>

<div class="clearBoth"></div>
<div id="leaderboard2015">
<ins data-revive-zoneid="3" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
</div> 

</div>


 <div class="clearLeft"></div> 
  </div>
  
  
<div id="bandeauBasFooter"><div id="bandeauBasFooter2">
    <div id="copyright">
	<!--sphider_noindex-->
	<p><strong>© 2020 Design And Reuse</strong></p> <p>All Rights Reserved.</p>
	<p style="font-weight: normal;">No portion of this site may be copied, retransmitted, reposted, duplicated or otherwise used without the express written permission of Design And Reuse.</p> 
	</div>
<!--
	<div class="colonne sansBordure">
    <h4 style="font-size: 16px;">Give us your feedback</h4>
	<p style="height:50px">Was this page helpful?<br/>Ask us a question or get help<br/><br/></p>
		<div class="sitebutton">
		<a href="/contact/" title="Talk to us" id="talktous"  rel="nofollow">Talk to us</a>					
        </div>
	</div>
	-->
                
	<div class="colonne sansBordure">
	<h4 style="font-size: 16px;">Partner with us</h4>
	<p style="height:50px">
	Visit our new Partnership Portal for more information.
	<br/><br/></p>
				<div class="sitebutton">
				<a href="https://www.design-reuse-embedded.com/join-dr/" id="talktous"  rel="nofollow">Partner with us</a>
				</div>
	</div>             
	
	<div class="colonne hid980">
	<h4 style="font-size: 16px;">List your Products</h4>
	<p style="height:50px">Suppliers, list
	your IPs for free.<br/><br/></p>
				<div class="sitebutton">
									<a href="/map/providers/" id="addproducts">List your Products</a>

						</div>
	</div>

	<div class="colonne">
	<h4 style="font-size: 16px;">Design-Reuse.com</h4>
	<ul>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/contact/">Contact Us</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/products/about.php">About us</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/partners/">D&amp;R Partner Program</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/ads/">Advertise with Us</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/privacy/">Privacy Policy</a></li>
	</ul>
	

	</div>


</div></div>



</section>


	<script type="application/javascript" src="https://static.designandreuse.com/staticdefault-20150421.js"></script>
	




					<div id="flosensing"></div>
	<script type="text/javascript">
	$( "#flosensing" ).append( "<img src=\"//www.design-reuse.com/flosensing/lg.php?url=%2Findustryexpertblogs%2F47679%2Fmemory-systems-for-ai-part-4.html%3Futm_medium%3Drss%26utm_source%3Ddesignreuse%26utm_content%3D1%26utm_campaign%3D47679&c=industryexpertblogs&action=view&prod=47679&prov=1644&ref=\" width=\"1\" height=\"1\">");

	</script>
		
			<script type="text/javascript">
			$( "#flosensing" ).append( "<img src=\"//www.design-reuse.com/popularity/47679.gif\" width=\"1\" height=\"1\">");

			</script>		
			
		
	

<script async src="//www.us.design-reuse.com/adserver/www/delivery/asyncjs.php"></script>
</body>
</html>