<!DOCTYPE html>
<html lang="en">
<head>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-118253-2"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-118253-2');
</script>
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=no" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
<title>Compute Express Link Controller IP Designed to the CXL Link Specification with AMBA Interfaces Optimized for SoC Implementations</title>
<meta http-equiv="Cache-Control" content="no-cache"/>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<link rel="shortcut icon" href="//static.designandreuse.com/IMAGES/favicon.ico" />
<link rel="alternate" type="application/rss+xml" title="All D and R Feeds" href="https://www.design-reuse.com/xml/1/1/all/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Headline News" href="https://www.design-reuse.com/xml/1/1/news/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Industry Articles" href="https://www.design-reuse.com/xml/1/1/articles/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R New Products" href="https://www.design-reuse.com/xml/1/1/products/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Wanted IPs" href="https://www.design-reuse.com/xml/1/1/wanted/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Industry Expert Blogs" href="https://www.design-reuse.com/xml/1/1/blogs/rss.xml"/>
<meta name="description" content="XpressLINK-SOC™ is a parameterizable Compute Express Link (CXL) controller Soft IP designed for ASIC and FPGA implementation. The XpressLINK-SOC Controller ..."/>
<meta name="keywords" content="cxl, compute express link, axi, compute express link controller ip designed to the cxl link specification with amba interfaces optimized for soc implementations, xpresslink-soc, ip core, silicon ip, semiconductor ip"/>
<!--sphider_noindex--> 
<meta http-equiv="Pragma" content="no-cache"/>
<meta name="Expires" content="Fri, 01 Jan 1990 00:00:00 GMT"/>
<meta name="robots" content="noarchive"/><!--[if lte IE 8]>
<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>

<script src="https://www.design-reuse.com//jscript/respond.min.js"></script>
<![endif]-->
	<link rel="stylesheet" type="text/css" href="https://static.designandreuse.com/staticcatalog-20200213.css"/>

</head>
<body>

<form>
<input id="menu-toggle" class="menu-toggle" type="checkbox">
<nav>
	<div class="menu">
	<ul>
		<li><a href="https://www.design-reuse.com/">Home</a></li>
		<li><a href="https://www.design-reuse.com/sip/">Search Silicon IP</a></li>
		<li><a href="https://www.design-reuse.com/vip/">Search Verification IP</a></li>
		<li><a href="https://www.design-reuse.com/news/">Latest News</a></li>
		<li><a href="https://www.design-reuse.com/articles/">Industry Articles</a></li>
		<li><a href="https://www.design-reuse.com/industryexpertblogs/">Industry Expert Blogs</a></li>
		<li><a href="https://www.design-reuse.com/video/">Videos</a></li>
		<li><a href="https://www.design-reuse.com/slides/">Slides</a></li>
 
	</ul>
  </div> 
</nav>
<section id="contentfull">
<div class="top-bar">
  <label for="menu-toggle" id="toggle">&equiv; <span>Menu</span></label> 
  
  <a id="drlogoS" href="https://www.design-reuse.com/">Design And Reuse</a>

<ul id="top-bar-subscribe" style="margin-right:15px; margin-top:5px">

			<li class="d-inline" >
		<a class="login c7 sz11" href="https://www.design-reuse.com/login2.php?nexturl=https%3A%2F%2Fwww.design-reuse.com%2Fsip%2Fcompute-express-link-controller-ip-designed-to-the-cxl-link-specification-with-amba-interfaces-optimized-for-soc-implementations-ip-48406%2F">Login</a>
		</li>
		<li class="c5 sz11 d-inline">|</li>
		

	<li id="nav-login167156" class="d-inline">
	<a class="login c7 sz11" href="https://www.design-reuse.com/users/signup.php">Subscribe</a>
	</li>


</ul>
  </div> 
</form>
<div id="bandeau-nav167156">
<div class="list grid-980">

<ul id="nav-right167156" class="nav-right">


<li class="d-inline">
<a class="c7 sz11" href="https://www.design-reuse.com/about/">Company</a>
</li>
<li class="c5 sz11 d-inline">|</li>

<li class="d-inline">
<a class="c7 sz11" href="https://www.design-reuse.com/foundry/siliconip/cn.php">D&amp;R China</a>
</li>
<li class="c5 sz11 d-inline">|</li>
<li class="d-inline">
<a class="c7 sz11" href="https://www.design-reuse.com/foundry/siliconip/drembedded3.php" rel="nofollow">dr-embedded.com</a>
</li>

<li class="c5 sz11 d-inline">|</li>
<li class="d-inline">
<a class="c7 sz11" href="http://www.design-reuse-enterprise.com/" rel="nofollow">D&amp;R Products</a>
</li>
<li class="c5 sz11 d-inline">|</li>
 
<li class="d-inline dropdown">
<span class="c7 sz11" ><img src="https://static.designandreuse.com/img16/cn.png" width="21" height="16" style="margin-top:4px; margin-right:10px"></span>
  <div class="dropdown-content">
    <a href="https://www.design-reuse.com/" class="c5 sz11 d-inline"> <img src="https://static.designandreuse.com/img16/en.png" width="16" height="12" style="margin-top:4px;"> English</a>
    <a href="https://www.design-reuse.com/foundry/siliconip/cn.php" class="c5 sz11 d-inline"><img src="https://static.designandreuse.com/img16/cn.png" width="16" height="12" style="margin-top:4px"> Chinese</a>
  </div>
</li>

 
<style>
.dropdown {
    position: relative;
    display: inline-block;
	cursor: pointer;
}

.dropdown-content {
    display: none;
    position: absolute;
    background-color: white;
    min-width: 80px;
    box-shadow: 0px 8px 16px 0px rgba(0,0,0,0.2);
    padding: 2px;
	z-index: 99999;
	margin-top: -8px;
}

.dropdown:hover .dropdown-content {
    display: block;
}

.dropdown-content a {
    color: black;
    padding: 1px;
    text-decoration: none;
    display: block;
}
.dropdown-content a:hover {background-color: #f1f1f1}
</style>
			<li class="d-inline" >
		<a class="login c7 sz11" href="https://www.design-reuse.com/login2.php?nexturl=https%3A%2F%2Fwww.design-reuse.com%2Fsip%2Fcompute-express-link-controller-ip-designed-to-the-cxl-link-specification-with-amba-interfaces-optimized-for-soc-implementations-ip-48406%2F">Login</a>
		</li>
		<li class="c5 sz11 d-inline">|</li>
		

	<li id="nav-login167156" class="d-inline">
	<a class="login c7 sz11" href="https://www.design-reuse.com/users/signup.php">Subscribe to D&amp;R SoC News Alert</a>
	</li>


</ul>
</div>
</div>
<div id="leadeboard"><div id="leadeboard-in" >
	<a href="https://www.design-reuse.com/" id="drlogo">Design And Reuse</a>
	
</div></div> 
<div id="center">
    <div class="outter"></div>
    <div id="mainmenu" class="navigation navigation2012">
        <ul id="menu-bar">
            <li id="nav_onglet_1" class=" actu">
                <a href="https://www.design-reuse.com/sip/" class="imaged"><span class="text">Search IP</span><span class="drop"></span></a>
				<ul class="ombrage">
				
                    <li class="first">
					     <span>Categories</span>
                        <div class="ul">
                            <ul>
                                <li class="first"><a href="https://www.design-reuse.com/sip/"><strong>Silicon IP</strong></a></li>
                                <li><a href="https://www.design-reuse.com/sip/analog-mixed-signal-c-3/">Analog & Mixed Signal</a></li>
                                <li><a href="https://www.design-reuse.com/sip/storage-controller-phy-c-5/">Storage Controller &amp; PHY</a></li>
                                <li><a href="https://www.design-reuse.com/sip/graphic-peripheral-c-6/">Graphic &amp; Peripheral</a></li>
                                <li><a href="https://www.design-reuse.com/sip/interfaces-c-7/">Interface Controller &amp; PHY</a></li>
                                <li><a href="https://www.design-reuse.com/sip/processors-microcontrollers-c-9/">Processors &amp; Microcontrollers</a></li>
                                <li><a href="https://www.design-reuse.com/sip/memory-logic-library-c-10/">Memory &amp; Logic Library</a></li>
                                <li><a href="https://www.design-reuse.com/sip/security-c-11/">Security</a></li>
                                <li><a href="https://www.design-reuse.com/sip/multimedia-c-12/">Multimedia</a></li>
                                <li><a href="https://www.design-reuse.com/sip/wireline-communication-c-13/">Wireline Communication</a></li>
                                <li><a href="https://www.design-reuse.com/sip/wireless-communication-c-14/">Wireless Communication</a></li>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/sip/provider.php"><strong>Silicon IP Vendors</strong></a>
                                </li>



								
                            </ul>
                        </div>
                    </li>

					
                   <li>
						<span>&nbsp;</span>

                        <div class="ul">
							<ul>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/vip/"><strong>Verification IP</strong></a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/vip/">Search / Browse</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/vip/provider.php">Verification IP Vendors</a>
                                </li>

	
					
									<li class="first">
                                    <a href="https://www.design-reuse.com/hds/"><strong>Software IP</strong></a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/hds/">Search / Browse</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/hds/provider.php">Software IP Vendors</a>
                                </li>
   	  		
                         
                                <li>
                                    <strong>&nbsp;</strong>
                                </li>
                                <li style="border-top:0px">
                                    <strong>&nbsp;</strong>
                                </li>
                                <li>
                                    <strong>Additional Services</strong>
                                </li>
													
	                                <li>
                                    <a href="https://www.design-reuse.com/sip/wanted/">Wanted IPs</a>
                                </li>
   	  	
                                <li>
                                    <a href="https://www.design-reuse.com/ipanalytics/">IP Analytics</a>
                                </li>
                            </ul>
                        </div>
                    </li>
					
					<li>
						<a href="https://www.design-reuse.com/sip/">	
						Featured Products</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="https://www.design-reuse.com/sip/mipi-m-phy-v3-1-ip-in-tsmc-12-16nm-28nm-40nm-and-55nm-ip-29842/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/m31tech.gif" alt="M31 Technology Corp." height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/mipi-m-phy-v3-1-ip-in-tsmc-12-16nm-28nm-40nm-and-55nm-ip-29842/">MIPI M-PHY v3.1 IP in TSMC(12/16nm, 28nm, 40nm, and 55nm)</a></p></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/sip/public-key-crypto-engine-ip-11804/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/silexinsight.gif" alt="Silex Insight" height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/public-key-crypto-engine-ip-11804/">Public Key Crypto Engine</a></p></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/sip/complete-usb-type-c-power-delivery-phy-rtl-and-software-ip-39798/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/obsidian.gif" alt="Obsidian Technology" height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/complete-usb-type-c-power-delivery-phy-rtl-and-software-ip-39798/">Complete USB Type-C Power Delivery  PHY, RTL, and Software</a></p></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/sip/otp-ip-ip-44796/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/cfx.gif" alt="Chuangfeixin Technologies" height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/otp-ip-ip-44796/">OTP IP</a></p></div></li>	     
						</ul></div>
						
                    </li>

                </ul>
				
            </li>
  		

	
					
	
            <li id="nav_onglet_3" class=" actu">
                <a href="https://www.design-reuse.com/news/" class="imaged"><span class="text">News</span><span class="drop"></span></a>
              <ul>
                    <li class="first">
                        <span>Categories</span>
                        <div class="ul">
                            <ul>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/news/semiconductor-ip-soc-0.html">IP/SoC Products </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/embedded-systems-0.html">Embedded Systems </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/foundries-0.html">Foundries</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/fpga-0.html">FPGA </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/fabless-0.html">Fabless / IDM </a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/deals-0.html">Deals</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/legal-0.html">Legal</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/business-0.html">Business</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/financial-0.html">Financial Results</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/people-0.html">People</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/commentary-analysis-0.html">Commentary / Analysis</a>
                                </li> 
								<li>
                                    <a href="https://www.design-reuse.com/news/mostpopular"><strong>20 Most Popular News</strong></a>
                                </li>
                            </ul>
                        </div>
                    </li>
					<li>
                        <a href="https://www.design-reuse.com/news/">					
						Latest News</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="//www.design-reuse.com/news/49115/sysgo-pikeos-cobham-gaisler-risc-v-noel-v-leon.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news49115/gaisler.jpg"  alt="sysgo-pikeos-cobham-gaisler-risc-v-noel-v-leon" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="//www.design-reuse.com/news/49115/sysgo-pikeos-cobham-gaisler-risc-v-noel-v-leon.html">Porting PikeOS to NOEL-V and LEON: SYSGO and Cobham Gaisler Extend Cooperation around RISC-V</a></p><div class="meta">Monday Dec. 07, 2020</div></div></li>	<li><div class="media"><a href="//www.design-reuse.com/news/49114/dolphin-design-power-controller-ip.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news49114/dolphin.jpg"  alt="dolphin-design-power-controller-ip" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="//www.design-reuse.com/news/49114/dolphin-design-power-controller-ip.html">Dolphin Design unveil a new and improved version of its Power Controller IP - MAESTRO - to speed-up energy-efficient SoC design</a></p><div class="meta">Monday Dec. 07, 2020</div></div></li>	<li><div class="media"><a href="//www.design-reuse.com/news/49113/openfive-flex-logix-efpga.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news49113/flexlogix.jpg"  alt="openfive-flex-logix-efpga" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="//www.design-reuse.com/news/49113/openfive-flex-logix-efpga.html">OpenFive Licenses Flex Logix's eFPGA to Develop a Low Power Communications SoC Requiring a Large eFPGA</a></p><div class="meta">Monday Dec. 07, 2020</div></div></li>	     
						</ul></div>

						
                    </li>
                </ul>

            </li>
            <li id="nav_onglet_4" class=" actu">
                <a href="https://www.design-reuse.com/articles/" class="imaged"><span class="text">Industry Articles</span><span class="drop"></span></a>
              <ul>
                    <li class="first">
                        <span>Categories</span>
                        <div class="ul">
                            <ul>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/articles/semiconductor-ip-soc-0.html">IP/SoC Products </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/articles/embedded-systems-0.html">Embedded Systems </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/articles/foundries-0.html">Foundries</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/articles/fpga-0.html">FPGA </a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/articles/business-0.html">Business</a>
                                </li>
								<li>
                                    <a href="https://www.design-reuse.com/articles/mostpopular"><strong>20 Most Popular Articles</strong></a>
                                </li>
                            </ul>
                        </div>
                    </li>
					<li>
                        <a href="https://www.design-reuse.com/articles/">					
						Featured Articles</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="https://www.design-reuse.com/articles/49048/the-future-of-chip-design.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news49048/boulecristal.jpg"  alt="the-future-of-chip-design" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/articles/49048/the-future-of-chip-design.html">The Future Of Chip Design</a></p><div class="meta">Monday Nov. 23, 2020</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/articles/49011/seize-the-ethernet-tsn-opportunity.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news49011/comcores.jpg"  alt="seize-the-ethernet-tsn-opportunity" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/articles/49011/seize-the-ethernet-tsn-opportunity.html">Seize the Ethernet TSN Opportunity </a></p><div class="meta">Monday Nov. 16, 2020</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/articles/48995/mac-less-neural-inference-processor.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news48995/ocean.jpg"  alt="mac-less-neural-inference-processor" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/articles/48995/mac-less-neural-inference-processor.html">A MAC-less Neural Inference Processor Supporting Compressed, Variable Precision Weights</a></p><div class="meta">Thursday Nov. 12, 2020</div></div></li>	     
						</ul></div>

						
                    </li>
                </ul> 
            </li>
            <li id="nav_onglet_5" class=" actu">
                <a href="https://www.design-reuse.com/industryexpertblogs/" class="imaged"><span class="text">Blogs</span><span class="drop"></span></a>
               <ul>
 					<li>
                        <a href="https://www.design-reuse.com/industryexpertblogs/">					
						Industry Expert Blogs</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="https://www.design-reuse.com/industryexpertblogs/49107/ceo-interview-tony-pialis-of-alphawave-ip.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/industryexpertblogs/images/semiwiki.jpg"  alt="ceo-interview-tony-pialis-of-alphawave-ip" width="64" height="64" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/industryexpertblogs/49107/ceo-interview-tony-pialis-of-alphawave-ip.html">CEO Interview: Tony Pialis of Alphawave IP</a></p><div class="meta">SemiWiki - Daniel Nenni</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/industryexpertblogs/49060/open-source-vs-commercial-risc-v-licensing-models.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/industryexpertblogs/images/codasip2.jpg"  alt="open-source-vs-commercial-risc-v-licensing-models" width="64" height="64" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/industryexpertblogs/49060/open-source-vs-commercial-risc-v-licensing-models.html">Open Source vs Commercial RISC-V Licensing Models</a></p><div class="meta">Codasip Blog - Roddy Urquhart</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/industryexpertblogs/49050/bluetooth-le-audio.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/industryexpertblogs/images/imgtec.gif"  alt="bluetooth-le-audio" width="64" height="64" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/industryexpertblogs/49050/bluetooth-le-audio.html">Bluetooth LE Audio: Where Innovation, Market Needs and Inclusiveness Converge</a></p><div class="meta">With Imagination Blog - Shewan Yitayew, Imagination
</div></div></li>	     
						</ul></div>

						
                    </li>
                </ul>     
            </li>
            <li id="nav_onglet_6" class=" cols">
                <a href="https://www.design-reuse.com/video/" class="imaged nodrop"><span class="text">Videos</span></a>

            </li>
            <li id="nav_onglet_8" class=" cols">
                <a href="https://www.design-reuse.com/slides/" class="imaged nodrop"><span class="text">Slides</span></a>

            </li>

            <li id="nav_onglet_7" class=" cols">

					<a  rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2020/" class="imaged"><span class="text">Events</span><span class="drop"></span></a>
					<ul>
                    <li class="first">
					
					  <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2020/">IP-SOC  2020</a>

					<!--<span>Archives</span>-->
                        <div class="ul">
                            <ul>

								<li class="first">
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2019/">IP-SoC Days 2019</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2018/">IP-SoC Days 2018</a>
                                </li>
								<li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/">IP-SoC Days 2017</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2019/grenoble2019/">IP-SoC 2019</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2018/grenoble2018/program.jsp">IP-SoC 2018</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsoc2017/postEvent.jsp">IP-SoC 2017</a>
                                </li>
                          


                            </ul>
                        </div>
                    </li>

                </ul>
            </li>
 
        </ul>
		
<div id="search">
		<form method="get" action="https://www.design-reuse.com/search/"  style="top:0px; width:250px">
<ul id="searchFilter"><li class="filterBtn" onclick="return true" title="search filter">
<div class="searchDropdown">
<fieldset>
<legend>Choose a filter </legend>
<ul id="searchOptions">
<li><input id="areafull" type="radio" value="full" name="area"/><label for="areafull">Full Site Search</label></li>
<li><input id="areasip" type="radio" value="sip" checked="checked" name="area"/><label for="areasip">Silicon IP</label></li>
<li><input id="areavip" type="radio" value="vip" name="area"/><label for="areavip">Verification IP</label></li>
<li><input id="areahds" type="radio" value="hds" name="area"/><label for="areahds">Software IP</label></li>
<li><input id="areanews" type="radio" value="news" name="area"/><label for="areanews">News</label></li>
<li><input id="areaarticle" type="radio" value="articles" name="area"/><label for="areaarticle">Industry Articles</label></li>
</ul>
</fieldset>
</div>
</li>
</ul>
<input id="i" name="i" class="inset " type="text" maxlength="255" value="Search Silicon IP"/>
<input class="magBtn" type="submit" value="Search D&amp;R site" title="search"/>
</form></div>

    </div>
</div>


<div id="section">
<div id="global" class="viewip">


<!--/sphider_noindex--> 

<div id="content">


<div id="left800" class="bluelink">

	<span style="font-size: 11px; font-weight: bold;">You are here:</span>  
	<ul class="path">
	<li><a href="/sip/">Silicon IP Catalog</a></li> &gt; <li><a href='/sip/interface-controller-phy-c-7/'> Interface Controller & PHY </a></li> &gt; <li><a href='/sip/cxl-c-546/'> CXL  </a></li>	</ul><br/><br/>
		
	

	<h1  style="margin: 0px; padding:0px;">

	
	Compute Express Link Controller IP Designed to the CXL Link Specification with AMBA Interfaces Optimized for SoC Implementations 	
	
	</h1>


	<div id="wrapleft500"  class=" clearfix" >

	<div id="left500" class="bluelink " >
	<div id="preview">

		<div style="margin-top:10px; margin-bottom:10px">
	XpressLINK-SOC™ is a parameterizable Compute Express Link (CXL) controller Soft IP designed for ASIC and FPGA implementation. The XpressLINK-SOC Controller IP leverages PLDA's silicon proven XpressRICH-AXI Controller for PCIe 5.0 architecture for the CXL.io path, and adds the CXL.cache and CXL.mem paths specific to CXL. XpressLINK-SOC supports the AMBA® AXI™ Protocol Specification for CXL.io traffic, and either Intel CXL-cache/mem Protocol Interface (CPI) or a AMBA® AXI™ Protocol Specification for CXL.mem and CPI interface for CXL.cache traffic, or the AMBA® CXS Protocol Specification. XpressLINK-SOC also complies with the Intel PHY Interface for PCI Express (PIPE) specification version 5.x and supports the PIPE LPC and SERDES modes. The provided Graphical User Interface (GUI) Wizard allows designers to tailor the IP to their exact requirements, by enabling, disabling, and adjusting a vast array of parameters, including CXL device type, PIPE interface configuration, buffer sizes and latency, low power support, SR-IOV parameters, etc. for optimal throughput, latency, size and power. XpressLINK-SOC is extensively verified using commercial as well as homegrown VIP and testsuites, and has been integrated with a number of PCIe 5.0 PHY IP. </div> 
		

<br/>
<hr/>
</div>


	<h2 style="font-weight:normal; font-size: 14px;">
	View	
	  <b>Compute Express Link Controller IP Designed to the CXL Link Specification with AMBA Interfaces Optimized for SoC Implementations</b> 
	  	full description to...
	</h2>
	<div>
	<div style="float: left; width:270px; margin-right:20px">
	<ul><li>
	see the entire
	 <b>Compute Express Link Controller IP Designed to the CXL Link Specification with AMBA Interfaces Optimized for SoC Implementations</b> 
	datasheet		
		
	</li>
	<li> 
	get in contact with 
	  <b>Compute Express Link Controller IP Designed to the CXL Link Specification with AMBA Interfaces Optimized for SoC Implementations</b>  
	Supplier	
	</li>
	</ul>
	</div>
	
	<div style="float: left; width:185px; margin-top:20px">

	<style type="text/css">
	.btn-more-2, .hd li.on em, div.hd li.sparkle a, .hd, #mastheadbd .top, #mastheadbd, #doors li a, #today .ft li.on a{
	background-image:url(//www.us.design-reuse.com/img06/grd-1px_1.1.gif);
	background-repeat:repeat-x;
	}



	.btn-more-2{
	padding:1px 10px 2px;
	*padding:1px 5px 0;
	font:bold 100% arial;
	color:#000;
	cursor:pointer;
	width:180px;
	white-space:nowrap;
	border:1px solid #999b9a;
	background-color:#ce9200;
	background-position:0 -450px;
	cursor: pointer
	}


	</style>

	
	<form action="//www.design-reuse.com/users/join.php" name="contactprovider" method="get">
	<input type="hidden" name="productid" value="48406"/> 
	<input type="hidden" name="target" value="sip"/> 
	<input type="hidden" name="nexturl" value="https://www.design-reuse.com/sip/compute-express-link-controller-ip-designed-to-the-cxl-link-specification-with-amba-interfaces-optimized-for-soc-implementations-ip-48406/"/> 
	<input type="submit" class="btn-more-2" value="View Full Description"/><br/><br/>
	</form>
	
		

</div>
</div>



<div style="clear:both; padding-top:10px"><h2 class="ipdescription">Block Diagram of the Compute Express Link Controller IP Designed to the CXL Link Specification with AMBA Interfaces Optimized for SoC Implementations</h2>	<img src="//www.design-reuse.com/sip/blockdiagram/48406/20201207061637-main-cxlsoc2-1-.png" width="480" height="401" alt="Compute Express Link Controller IP Designed to the CXL Link Specification with AMBA Interfaces Optimized for SoC Implementations Block Diagam">
	<br/><br/>	    </div>

	

</div>
</div>
<div id="middle300" class="bluelink">
		<div class="bloc300 gradient">
		<h2 class="oswald"  style="margin-bottom: 15px;margin-top: 0px;">
		 CXL 
		 IP 
		 
		</h2>
			<div><div class="type1">
			<ul class="arrowList1" style="line-height: 13px; height: auto; border-bottom: 0px; padding: 0">
			
				<li><a href="//www.design-reuse.com/sip/47902/controller-ip-for-cxl/"  title="View Controller IP for CXL IP Description">  
		Controller IP for CXL		</a></li>
				<li><a href="//www.design-reuse.com/sip/47691/cxl-compute-express-link-dual-mode-controller/"  title="View CXL (Compute Express Link) Dual Mode Controller IP Description">  
		CXL (Compute Express Link) Dual Mode Controller		</a></li>
				<li><a href="//www.design-reuse.com/sip/47692/cxl-host-device-dual-mode-controllers/"  title="View CXL Host Device Dual mode controllers IP Description">  
		CXL Host Device Dual mode controllers		</a></li>
				<li><a href="//www.design-reuse.com/sip/48657/designware-cxl-2-0-controller-ip/"  title="View DesignWare CXL 2.0 Controller IP IP Description">  
		DesignWare CXL 2.0 Controller IP		</a></li>
				<li><a href="//www.design-reuse.com/sip/48481/cxl-controller-ip/"  title="View CXL CONTROLLER IP IP Description">  
		CXL CONTROLLER IP		</a></li>
				<li><a href="//www.design-reuse.com/sip/47439/pcie-5-0-serdes-phy/"  title="View PCIe 5.0 SerDes PHY IP Description">  
		PCIe 5.0 SerDes PHY		</a></li>
				</ul></div>
		</div>
		<div class="spaceboy" style="clear:both"> </div>
		<div  class="txtR" >
		<a  class="fcTheme ud"   style="color:#E41129;" href="//www.design-reuse.com/sip?q=cxl">See more CXL 
				 IP 
		 &gt;&gt;</a>
		</div>
		</div>
		

</div>
</div>
</div>
	<div id="right135">
	<!--sphider_noindex-->
	<ins data-revive-zoneid="5" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
	<br/><br/>
	<ins data-revive-zoneid="6" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
	<br/><br/>
	
<ins data-revive-zoneid="7" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
	<br/><br/>
		<!--/sphider_noindex-->
	</div>

<div class="clearBoth"></div>
<div id="leaderboard2015">
<ins data-revive-zoneid="3" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
</div> 

</div>


 <div class="clearLeft"></div> 
  </div>
  
  
<div id="bandeauBasFooter"><div id="bandeauBasFooter2">
    <div id="copyright">
	<!--sphider_noindex-->
	<p><strong>© 2020 Design And Reuse</strong></p> <p>All Rights Reserved.</p>
	<p style="font-weight: normal;">No portion of this site may be copied, retransmitted, reposted, duplicated or otherwise used without the express written permission of Design And Reuse.</p> 
	</div>
<!--
	<div class="colonne sansBordure">
    <h4 style="font-size: 16px;">Give us your feedback</h4>
	<p style="height:50px">Was this page helpful?<br/>Ask us a question or get help<br/><br/></p>
		<div class="sitebutton">
		<a href="/contact/" title="Talk to us" id="talktous"  rel="nofollow">Talk to us</a>					
        </div>
	</div>
	-->
                
	<div class="colonne sansBordure">
	<h4 style="font-size: 16px;">Partner with us</h4>
	<p style="height:50px">
	<br/>
	<br/><br/></p>
				<div class="sitebutton">
				<a href="https://www.design-reuse-embedded.com/join-dr/" id="talktous"  rel="nofollow">Partner with us</a>
				</div>
	</div>             
	
	<div class="colonne hid980">
	<h4 style="font-size: 16px;">List your Products</h4>
	<p style="height:50px">Suppliers, list
	your IPs for free.<br/><br/></p>
				<div class="sitebutton">
									<a href="/map/providers/" id="addproducts">List your Products</a>

						</div>
	</div>

	<div class="colonne">
	<h4 style="font-size: 16px;">Design-Reuse.com</h4>
	<ul>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/contact/">Contact Us</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/products/about.php">About us</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/partners/">D&amp;R Partner Program</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/ads/">Advertise with Us</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/privacy/">Privacy Policy</a></li>
	</ul>
	

	</div>


</div></div>



</section>


	<script type="application/javascript" src="https://static.designandreuse.com/staticdefault-20150421.js"></script>
	



<script type="text/javascript">
var pathurl = "https://www.design-reuse.com/sip/";
var thispageid= "";
var backurl= "%2Fsip%2Fcompute-express-link-controller-ip-designed-to-the-cxl-link-specification-with-amba-interfaces-optimized-for-soc-implementations-ip-48406%2F";
</script> 


<script type="text/javascript">
$(document).ready(function() {
    $('ul#iplist li').mouseover(function(){
          $(this).find('div.data div.ipdetail').css('display','inline');
    });
    $('ul#iplist li').mouseout(function(){
          $(this).find('div.data div.ipdetail').css('display','none');
    });
});

</script> 
	<script type="text/javascript" src="https://static.designandreuse.com/jscript/jquery.qtip.min.js"></script>
	<script type="text/javascript" src="https://static.designandreuse.com/jscript/catalog12.js?5"></script>
	
			
<script type="text/javascript" src="https://static.designandreuse.com/jscript/anylinkcssmenu.js">
/***********************************************
* AnyLink CSS Menu script v2.0- © Dynamic Drive DHTML code library (www.dynamicdrive.com)
* This notice MUST stay intact for legal use
* Visit Project Page at http://www.dynamicdrive.com/dynamicindex1/anylinkcss.htm for full source code
***********************************************/
</script>
<script type="text/javascript">

$(document).ready(function () {
    $('#showrefine').click(function () {
    $('#left200').toggle('500');
    $('#showrefine').toggle();
    });    
    $('#closerefine').click(function () {
    $('#left200').toggle('500');
    $('#showrefine').toggle();
    });    
});
</script>




					<div id="flosensing"></div>
	<script type="text/javascript">
	$( "#flosensing" ).append( "<img src=\"//www.design-reuse.com/flosensing/lg.php?url=%2Fsip%2Fcompute-express-link-controller-ip-designed-to-the-cxl-link-specification-with-amba-interfaces-optimized-for-soc-implementations-ip-48406%2F&c=sip&action=preview&prod=48406&prov=84&ref=\" width=\"1\" height=\"1\">");

	</script>
			
		
	

<script async src="//www.us.design-reuse.com/adserver/www/delivery/asyncjs.php"></script>
</body>
</html>