<!DOCTYPE html>
<html lang="en">
<head>
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=no" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
<title>Single issue, embedded RISC-V core with 4-stage pipeline</title>
<meta http-equiv="Cache-Control" content="no-cache"/>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<link rel="shortcut icon" href="//static.designandreuse.com/IMAGES/favicon.ico" />
<link rel="alternate" type="application/rss+xml" title="All D and R Feeds" href="https://www.design-reuse.com/xml/1/1/all/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Headline News" href="https://www.design-reuse.com/xml/1/1/news/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Industry Articles" href="https://www.design-reuse.com/xml/1/1/articles/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R New Products" href="https://www.design-reuse.com/xml/1/1/products/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Wanted IPs" href="https://www.design-reuse.com/xml/1/1/wanted/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Industry Expert Blogs" href="https://www.design-reuse.com/xml/1/1/blogs/rss.xml"/>
<meta name="description" content="The Western Digital SweRV Core™ EL2 is a single issue, RV32IMC, single-issue core with a 4-stage in-order pipeline. Like the EH1 and EH2, it supports ..."/>
<meta name="keywords" content="risc-v, riscv, 32-bit, ide, toolchain, eda flow, dual-issue,iss,high performance, 4-stage pipeline, swerv, single issue, embedded risc-v core with 4-stage pipeline, swerv core el2, ip core, silicon ip, semiconductor ip"/>
<!--sphider_noindex--> 
<meta http-equiv="Pragma" content="no-cache"/>
<meta name="Expires" content="Fri, 01 Jan 1990 00:00:00 GMT"/>
<meta name="robots" content="noarchive"/><!--[if lte IE 8]>
<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>

<script src="https://www.design-reuse.com//jscript/respond.min.js"></script>
<![endif]-->
	<link rel="stylesheet" type="text/css" href="https://static.designandreuse.com/staticcatalog-20200213.css"/>

</head>
<body>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-118253-2', 'auto');
  ga('send', 'pageview');

</script>
<form>
<input id="menu-toggle" class="menu-toggle" type="checkbox">
<nav>
	<div class="menu">
	<ul>
		<li><a href="https://www.design-reuse.com/">Home</a></li>
		<li><a href="https://www.design-reuse.com/sip/">Search Silicon IP</a></li>
		<li><a href="https://www.design-reuse.com/vip/">Search Verification IP</a></li>
		<li><a href="https://www.design-reuse.com/news/">Latest News</a></li>
		<li><a href="https://www.design-reuse.com/articles/">Industry Articles</a></li>
		<li><a href="https://www.design-reuse.com/industryexpertblogs/">Industry Expert Blogs</a></li>
		<li><a href="https://www.design-reuse.com/video/">Videos</a></li>
		<li><a href="https://www.design-reuse.com/slides/">Slides</a></li>
 
	</ul>
  </div> 
</nav>
<section id="contentfull">
<div class="top-bar">
  <label for="menu-toggle" id="toggle">&equiv; <span>Menu</span></label> 
  
  <a id="drlogoS" href="https://www.design-reuse.com/">Design And Reuse</a>

<ul id="top-bar-subscribe" style="margin-right:15px; margin-top:5px">

			<li class="d-inline" >
		<a class="login c7 sz11" href="https://www.design-reuse.com/login2.php?nexturl=https%3A%2F%2Fwww.design-reuse.com%2Fsip%2Fsingle-issue-embedded-risc-v-core-with-4-stage-pipeline-ip-48159%2F">Login</a>
		</li>
		<li class="c5 sz11 d-inline">|</li>
		

	<li id="nav-login167156" class="d-inline">
	<a class="login c7 sz11" href="https://www.design-reuse.com/users/signup.php">Subscribe</a>
	</li>


</ul>
  </div> 
</form>
<div id="bandeau-nav167156">
<div class="list grid-980">

<ul id="nav-right167156" class="nav-right">


<li class="d-inline">
<a class="c7 sz11" href="https://www.design-reuse.com/about/">Company</a>
</li>
<li class="c5 sz11 d-inline">|</li>

<li class="d-inline">
<a class="c7 sz11" href="https://www.design-reuse.com/foundry/siliconip/cn.php">D&amp;R China</a>
</li>
<li class="c5 sz11 d-inline">|</li>
<li class="d-inline">
<a class="c7 sz11" href="https://www.design-reuse.com/foundry/siliconip/drembedded3.php" rel="nofollow">dr-embedded.com</a>
</li>

<li class="c5 sz11 d-inline">|</li>
<li class="d-inline">
<a class="c7 sz11" href="http://www.design-reuse-enterprise.com/" rel="nofollow">D&amp;R Products</a>
</li>
<li class="c5 sz11 d-inline">|</li>
 
<li class="d-inline dropdown">
<span class="c7 sz11" ><img src="https://static.designandreuse.com/img16/cn.png" width="21" height="16" style="margin-top:4px; margin-right:10px"></span>
  <div class="dropdown-content">
    <a href="https://www.design-reuse.com/" class="c5 sz11 d-inline"> <img src="https://static.designandreuse.com/img16/en.png" width="16" height="12" style="margin-top:4px;"> English</a>
    <a href="https://www.design-reuse.com/foundry/siliconip/cn.php" class="c5 sz11 d-inline"><img src="https://static.designandreuse.com/img16/cn.png" width="16" height="12" style="margin-top:4px"> Chinese</a>
  </div>
</li>

 
<style>
.dropdown {
    position: relative;
    display: inline-block;
	cursor: pointer;
}

.dropdown-content {
    display: none;
    position: absolute;
    background-color: white;
    min-width: 80px;
    box-shadow: 0px 8px 16px 0px rgba(0,0,0,0.2);
    padding: 2px;
	z-index: 99999;
	margin-top: -8px;
}

.dropdown:hover .dropdown-content {
    display: block;
}

.dropdown-content a {
    color: black;
    padding: 1px;
    text-decoration: none;
    display: block;
}
.dropdown-content a:hover {background-color: #f1f1f1}
</style>
			<li class="d-inline" >
		<a class="login c7 sz11" href="https://www.design-reuse.com/login2.php?nexturl=https%3A%2F%2Fwww.design-reuse.com%2Fsip%2Fsingle-issue-embedded-risc-v-core-with-4-stage-pipeline-ip-48159%2F">Login</a>
		</li>
		<li class="c5 sz11 d-inline">|</li>
		

	<li id="nav-login167156" class="d-inline">
	<a class="login c7 sz11" href="https://www.design-reuse.com/users/signup.php">Subscribe to D&amp;R SoC News Alert</a>
	</li>


</ul>
</div>
</div>
<div id="leadeboard"><div id="leadeboard-in" >
	<a href="https://www.design-reuse.com/" id="drlogo">Design And Reuse</a>
	
</div></div> 
<div id="center">
    <div class="outter"></div>
    <div id="mainmenu" class="navigation navigation2012">
        <ul id="menu-bar">
            <li id="nav_onglet_1" class=" actu">
                <a href="https://www.design-reuse.com/sip/" class="imaged"><span class="text">Search IP</span><span class="drop"></span></a>
				<ul class="ombrage">
				
                    <li class="first">
					     <span>Categories</span>
                        <div class="ul">
                            <ul>
                                <li class="first"><a href="https://www.design-reuse.com/sip/"><strong>Silicon IP</strong></a></li>
                                <li><a href="https://www.design-reuse.com/sip/analog-mixed-signal-c-3/">Analog & Mixed Signal</a></li>
                                <li><a href="https://www.design-reuse.com/sip/storage-controller-phy-c-5/">Storage Controller &amp; PHY</a></li>
                                <li><a href="https://www.design-reuse.com/sip/graphic-peripheral-c-6/">Graphic &amp; Peripheral</a></li>
                                <li><a href="https://www.design-reuse.com/sip/interfaces-c-7/">Interface Controller &amp; PHY</a></li>
                                <li><a href="https://www.design-reuse.com/sip/processors-microcontrollers-c-9/">Processors &amp; Microcontrollers</a></li>
                                <li><a href="https://www.design-reuse.com/sip/memory-logic-library-c-10/">Memory &amp; Logic Library</a></li>
                                <li><a href="https://www.design-reuse.com/sip/security-c-11/">Security</a></li>
                                <li><a href="https://www.design-reuse.com/sip/multimedia-c-12/">Multimedia</a></li>
                                <li><a href="https://www.design-reuse.com/sip/wireline-communication-c-13/">Wireline Communication</a></li>
                                <li><a href="https://www.design-reuse.com/sip/wireless-communication-c-14/">Wireless Communication</a></li>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/sip/provider.php"><strong>Silicon IP Vendors</strong></a>
                                </li>



								
                            </ul>
                        </div>
                    </li>

					
                   <li>
						<span>&nbsp;</span>

                        <div class="ul">
							<ul>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/vip/"><strong>Verification IP</strong></a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/vip/">Search / Browse</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/vip/provider.php">Verification IP Vendors</a>
                                </li>

	
					
	  		
                         
                                <li>
                                    <strong>&nbsp;</strong>
                                </li>
                                <li style="border-top:0px">
                                    <strong>&nbsp;</strong>
                                </li>
                                <li>
                                    <strong>Additional Services</strong>
                                </li>
													
	                                <li>
                                    <a href="https://www.design-reuse.com/sip/wanted/">Wanted IPs</a>
                                </li>
   	  	
                                <li>
                                    <a href="https://www.design-reuse.com/ipanalytics/">IP Analytics</a>
                                </li>
                            </ul>
                        </div>
                    </li>
					
					<li>
						<a href="https://www.design-reuse.com/sip/">	
						Featured Products</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="https://www.design-reuse.com/sip/usb-3-1-superspeed-gen2-device-controller-usb-if-certified-ip-42495/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/corigine.gif" alt="Corigine Inc." height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/usb-3-1-superspeed-gen2-device-controller-usb-if-certified-ip-42495/">USB 3.1 SuperSpeed+ (Gen2) Device Controller (USB-IF Certified)</a></p></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/sip/high-speed-noc-network-on-chip-interconnect-ip-ip-44588/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/openedges.gif" alt="OPENEDGES Technology, Inc." height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/high-speed-noc-network-on-chip-interconnect-ip-ip-44588/">High speed NoC (Network On-Chip) Interconnect IP</a></p></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/sip/camera-capture-unit-for-multi-camera-systems-ip-47151/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/socionext2.gif" alt="Socionext Europe GmbH" height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/camera-capture-unit-for-multi-camera-systems-ip-47151/">Camera capture unit for multi-camera systems</a></p></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/sip/12-bit-high-performance-dac-for-802-11ac-ip-35345/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/pcsemi.gif" alt="Palma Ceia SemiDesign, Inc." height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/12-bit-high-performance-dac-for-802-11ac-ip-35345/">12-Bit High-Performance DAC for 802.11ac</a></p></div></li>	     
						</ul></div>
						
                    </li>

                </ul>
				
            </li>
  		

	
					
	
            <li id="nav_onglet_3" class=" actu">
                <a href="https://www.design-reuse.com/news/" class="imaged"><span class="text">News</span><span class="drop"></span></a>
              <ul>
                    <li class="first">
                        <span>Categories</span>
                        <div class="ul">
                            <ul>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/news/semiconductor-ip-soc-0.html">IP/SoC Products </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/embedded-systems-0.html">Embedded Systems </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/foundries-0.html">Foundries</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/fpga-0.html">FPGA </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/fabless-0.html">Fabless / IDM </a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/deals-0.html">Deals</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/legal-0.html">Legal</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/business-0.html">Business</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/financial-0.html">Financial Results</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/people-0.html">People</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/commentary-analysis-0.html">Commentary / Analysis</a>
                                </li> 
								<li>
                                    <a href="https://www.design-reuse.com/news/mostpopular"><strong>20 Most Popular News</strong></a>
                                </li>
                            </ul>
                        </div>
                    </li>
					<li>
                        <a href="https://www.design-reuse.com/news/">					
						Latest News</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="//www.design-reuse.com/news/48231/dolphin-dsp-digital-platforms.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news48231/dolphin.jpg"  alt="dolphin-dsp-digital-platforms" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="//www.design-reuse.com/news/48231/dolphin-dsp-digital-platforms.html">Dolphin unveils two break-through DSP and AI digital platforms dedicated to edge computing applications</a></p><div class="meta">Monday Jun. 29, 2020</div></div></li>	<li><div class="media"><a href="//www.design-reuse.com/news/48230/palma-ceia-pcs11ax28-802-11ax-transceiver.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news48230/palma2.jpg"  alt="palma-ceia-pcs11ax28-802-11ax-transceiver" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="//www.design-reuse.com/news/48230/palma-ceia-pcs11ax28-802-11ax-transceiver.html">Palma Ceia SemiDesign Announces Sampling for PCS11ax28, New 802.11ax Transceiver</a></p><div class="meta">Monday Jun. 29, 2020</div></div></li>	<li><div class="media"><a href="//www.design-reuse.com/news/48229/dialog-semiconductor-adesto-acquisition-completion.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news48229/acquisition.jpg"  alt="dialog-semiconductor-adesto-acquisition-completion" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="//www.design-reuse.com/news/48229/dialog-semiconductor-adesto-acquisition-completion.html">Dialog Semiconductor Announces Completion of its Acquisition of Adesto Technologies</a></p><div class="meta">Monday Jun. 29, 2020</div></div></li>	     
						</ul></div>

						
                    </li>
                </ul>

            </li>
            <li id="nav_onglet_4" class=" actu">
                <a href="https://www.design-reuse.com/articles/" class="imaged"><span class="text">Industry Articles</span><span class="drop"></span></a>
              <ul>
                    <li class="first">
                        <span>Categories</span>
                        <div class="ul">
                            <ul>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/articles/semiconductor-ip-soc-0.html">IP/SoC Products </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/articles/embedded-systems-0.html">Embedded Systems </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/articles/foundries-0.html">Foundries</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/articles/fpga-0.html">FPGA </a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/articles/business-0.html">Business</a>
                                </li>
								<li>
                                    <a href="https://www.design-reuse.com/articles/mostpopular"><strong>20 Most Popular Articles</strong></a>
                                </li>
                            </ul>
                        </div>
                    </li>
					<li>
                        <a href="https://www.design-reuse.com/articles/">					
						Featured Articles</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="https://www.design-reuse.com/articles/48227/antenna-effect-in-16nm-technology-node.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news48227/einfo.jpg"  alt="antenna-effect-in-16nm-technology-node" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/articles/48227/antenna-effect-in-16nm-technology-node.html">Antenna Effect in 16nm Technology Node  </a></p><div class="meta">Monday Jun. 29, 2020</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/articles/48219/analog-and-power-management-trends-in-asic-and-soc-designs.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news48219/power.jpg"  alt="analog-and-power-management-trends-in-asic-and-soc-designs" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/articles/48219/analog-and-power-management-trends-in-asic-and-soc-designs.html">Analog and Power Management Trends in ASIC and SoC Designs</a></p><div class="meta">Monday Jun. 29, 2020</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/articles/48207/geolocation-signal-processing.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news48207/FIG.jpg"  alt="geolocation-signal-processing" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/articles/48207/geolocation-signal-processing.html">Where Innovation Is Happening in Geolocation. Part 1: Signal Processing</a></p><div class="meta">Thursday Jun. 25, 2020</div></div></li>	     
						</ul></div>

						
                    </li>
                </ul> 
            </li>
            <li id="nav_onglet_5" class=" actu">
                <a href="https://www.design-reuse.com/industryexpertblogs/" class="imaged"><span class="text">Blogs</span><span class="drop"></span></a>
               <ul>
 					<li>
                        <a href="https://www.design-reuse.com/industryexpertblogs/">					
						Industry Expert Blogs</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="https://www.design-reuse.com/industryexpertblogs/48222/securing-network-traffic-using-macsec-over-ethernet.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/industryexpertblogs/images/vipexperts.jpg?2"  alt="securing-network-traffic-using-macsec-over-ethernet" width="64" height="64" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/industryexpertblogs/48222/securing-network-traffic-using-macsec-over-ethernet.html">Securing Network Traffic using MACSec Over Ethernet</a></p><div class="meta">VIP Experts Blog - Synopsys</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/industryexpertblogs/48210/apple-s-silicon-switch-changes-game-balance.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/industryexpertblogs/images/semiwiki.jpg"  alt="apple-s-silicon-switch-changes-game-balance" width="64" height="64" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/industryexpertblogs/48210/apple-s-silicon-switch-changes-game-balance.html">Apple's silicon switch changes game &amp; balance </a></p><div class="meta">SemiWiki - Robert Maire, SemiWiki</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/industryexpertblogs/48205/is-arm-going-home.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/industryexpertblogs/images/davidmanners.jpg"  alt="is-arm-going-home" width="64" height="64" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/industryexpertblogs/48205/is-arm-going-home.html">Is Arm Going Home?</a></p><div class="meta">Mannerisms - David Manners</div></div></li>	     
						</ul></div>

						
                    </li>
                </ul>     
            </li>
            <li id="nav_onglet_6" class=" cols">
                <a href="https://www.design-reuse.com/video/" class="imaged nodrop"><span class="text">Videos</span></a>

            </li>
            <li id="nav_onglet_8" class=" cols">
                <a href="https://www.design-reuse.com/slides/" class="imaged nodrop"><span class="text">Slides</span></a>

            </li>

            <li id="nav_onglet_7" class=" cols">

					<a  rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2020/" class="imaged"><span class="text">Events</span><span class="drop"></span></a>
					<ul>
                    <li class="first">
					
					  <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2020/">IP-SOC  2020</a>

					<!--<span>Archives</span>-->
                        <div class="ul">
                            <ul>

								<li class="first">
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2019/">IP-SoC Days 2019</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2018/">IP-SoC Days 2018</a>
                                </li>
								<li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/">IP-SoC Days 2017</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2019/grenoble2019/">IP-SoC 2019</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2018/grenoble2018/program.jsp">IP-SoC 2018</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsoc2017/postEvent.jsp">IP-SoC 2017</a>
                                </li>
                          


                            </ul>
                        </div>
                    </li>

                </ul>
            </li>
 
        </ul>
		
<div id="search">
		<form method="get" action="https://www.design-reuse.com/search/"  style="top:0px; width:250px">
<ul id="searchFilter"><li class="filterBtn" onclick="return true" title="search filter">
<div class="searchDropdown">
<fieldset>
<legend>Choose a filter </legend>
<ul id="searchOptions">
<li><input id="areafull" type="radio" value="full" name="area"/><label for="areafull">Full Site Search</label></li>
<li><input id="areasip" type="radio" value="sip" checked="checked" name="area"/><label for="areasip">Silicon IP</label></li>
<li><input id="areavip" type="radio" value="vip" name="area"/><label for="areavip">Verification IP</label></li>
<li><input id="areahds" type="radio" value="hds" name="area"/><label for="areahds">Software IP</label></li>
<li><input id="areanews" type="radio" value="news" name="area"/><label for="areanews">News</label></li>
<li><input id="areaarticle" type="radio" value="articles" name="area"/><label for="areaarticle">Industry Articles</label></li>
</ul>
</fieldset>
</div>
</li>
</ul>
<input id="i" name="i" class="inset " type="text" maxlength="255" value="Search Silicon IP"/>
<input class="magBtn" type="submit" value="Search D&amp;R site" title="search"/>
</form></div>

    </div>
</div>


<div id="section">
<div id="global" class="viewip">


<!--/sphider_noindex--> 

<div id="content">


<div id="left800" class="bluelink">

	<span style="font-size: 11px; font-weight: bold;">You are here:</span>  
	<ul class="path">
	<li><a href="/sip/">Silicon IP Catalog</a></li> &gt; <li><a href='/sip/processor-solutions-c-9/'> Processor Solutions </a></li> &gt; <li><a href='/sip/processor-cores-c-99/'>  Processor Cores </a></li> &gt; <li><a href='/sip/32-bit-microprocessor-c-62/'> 32-Bit Microprocessor </a></li>	</ul><br/><br/>
		
	

	<h1  style="margin: 0px; padding:0px;">

	
	Single issue, embedded RISC-V core with 4-stage pipeline 	
	
	</h1>


	<div id="wrapleft500"  class=" clearfix" >

	<div id="left500" class="bluelink " >
	<div id="preview">

		<div style="margin-top:10px; margin-bottom:10px">
	The Western Digital SweRV Core™ EL2 is a single issue, RV32IMC, single-issue core with a 4-stage in-order pipeline. Like the EH1 and EH2, it supports optional instruction and data closely coupled memories with ECC protection and optional 2- or 4-way set-associative instruction cache with parity or ECC protection (32- or 64-byte line size). It is rated at 3.6 CoreMark/MHz. The core has been open sourced through CHIPS Alliance. <br/>The SweRV Core Support Package (SCSP) contains everything needed to deploy a Western Digital SweRV™ EL2 core in an integrated circuit providing support for both EDA tool flows and embedded software development. SCSP saves the considerable effort that would be needed to set up EDA flows for the EL2 core from scratch. <br/>The SweRV Core Support Package for EL2 is available in both basic Free and Pro versions. <br/>The Free version consists of open-source deliverables and infrastructure for using open-source EDA tools and an SDK. Users can access a forum for support. <br/>The Pro version combines open source and commercial deliverables. It provides flows, examples and models for using commercial EDA tools. This version includes professional support. <br/></div> 
				<h2 class="ipdescription">Features</h2>
			<ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">SwerRV Core EL2</span></li><ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">   RV32IMC instructions</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Single issue</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   4-stage pipeline</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   2 stall points</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Instruction cache</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   3.6 CoreMarks/MHz</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   0.023mm2 in TSMC 16 nm</span></li></ul><li style="padding-bottom: 3px;"><span style="color:#333333">SweRV Core Support Package for EL2 Core</span></li><ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">   Free and Pro versions</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Support for open and commercial EDA tools</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Emulation using Digilent FPGA board</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Examples of bare metal and FreeRTOS    </span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Software</span></li></ul></ul> 
			<h2 class="ipdescription">Benefits</h2>


		 <ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">The SweRV Core Support Package provides a low risk way of deploying the SweRV Core EL2 core with either open-source or commercial EDA tools.</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Pre-defined EDA flows with differences between specific EDA tools abstracted from the user.</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">The package is complete supporting embedded software development, emulation, implementation and comprehensive debug.</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">The offering is flexible depending on the complexity of the EDA flows required.</span></li></ul> 
		
		<h2 class="ipdescription">Deliverables</h2>
	<ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">SweRV Core Support Package Free Version</span></li><ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">   Western Digital EL2 open RTL</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   IP-specific flows for open EDA tools</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Western Digital Whisper ISS</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   RISC-V GNU toolchain</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Eclipse IDE</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Open OCD debugging tool</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Codasip infrastructure for EDA & IP</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   User forum</span></li></ul><li style="padding-bottom: 3px;"><span style="color:#333333">SweRV Core Support Package Pro Version contains additionally</span></li><ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">   Flows for commercial simulators</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Flows for commercial synthesis tools</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Flows for commercial static code analysis   </span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Tools and equivalence checking</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">   Professional support from Codasip</span></li></ul></ul> 
		<h2 class="ipdescription">Applications</h2>
	<ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">Medium-performance 32-bit embedded applications such as storage, motor control, database engines and control systems for appliances.</span></li></ul> 
		
<h2 class="ipdescription">Block Diagram of the Single issue, embedded RISC-V core with 4-stage pipeline</h2>	<img src="//www.design-reuse.com/sip/blockdiagram/48159/20200603010023-main-SWeRV-EL2.png" width="480" height="317" alt="Single issue, embedded RISC-V core with 4-stage pipeline Block Diagam">
	<br/><br/>	    

	

<br/><br/>

<hr/>
</div>


	<h2 style="font-weight:normal; font-size: 14px;">
	View	
	  <b>Single issue, embedded RISC-V core with 4-stage pipeline</b> 
	  	full description to...
	</h2>
	<div style="float: left; width:270px">
	<ul><li>
	see the entire
	 <b>Single issue, embedded RISC-V core with 4-stage pipeline</b> 
	datasheet		
		
	</li>
	<li> 
	get in contact with 
	  <b>Single issue, embedded RISC-V core with 4-stage pipeline</b>  
	Supplier	
	</li>
	</ul>
	</div>
	<div style="float: left; width:185px; margin-top:20px">

	<style type="text/css">
	.btn-more-2, .hd li.on em, div.hd li.sparkle a, .hd, #mastheadbd .top, #mastheadbd, #doors li a, #today .ft li.on a{
	background-image:url(//www.us.design-reuse.com/img06/grd-1px_1.1.gif);
	background-repeat:repeat-x;
	}



	.btn-more-2{
	padding:1px 10px 2px;
	*padding:1px 5px 0;
	font:bold 100% arial;
	color:#000;
	cursor:pointer;
	width:180px;
	white-space:nowrap;
	border:1px solid #999b9a;
	background-color:#ce9200;
	background-position:0 -450px;
	cursor: pointer
	}


	</style>

	
	<form action="//www.design-reuse.com/users/join.php" name="contactprovider" method="get">
	<input type="hidden" name="productid" value="48159"/> 
	<input type="hidden" name="target" value="sip"/> 
	<input type="hidden" name="nexturl" value="https://www.design-reuse.com/sip/single-issue-embedded-risc-v-core-with-4-stage-pipeline-ip-48159/"/> 
	<input type="submit" class="btn-more-2" value="View Full Description"/><br/><br/>
	</form>
	
		

</div>
</div>
</div>
<div id="middle300" class="bluelink">
		<div class="bloc300 gradient">
		<h2 class="oswald"  style="margin-bottom: 15px;margin-top: 0px;">
		 RISC-V 
		 IP 
		 
		</h2>
			<div><div class="type1">
			<ul class="arrowList1" style="line-height: 13px; height: auto; border-bottom: 0px; padding: 0">
			
				<li><a href="//www.design-reuse.com/sip/47279/digital-and-mixed-signal-ip-and-asic-risc-v-reference-design-for-usb-type-c-pd-power-adapter-charger/"  title="View Digital and mixed-signal IP and ASIC RISC-V reference design for USB Type-C/PD power adapter/charger IP Description">  
		Digital and mixed-signal IP and ASIC RISC-V reference design for USB Type-C/PD power adapter/charger		</a></li>
				<li><a href="//www.design-reuse.com/sip/45620/low-power-32-bit-risc-v-processor/"  title="View Low-power 32-bit RISC-V processor IP Description">  
		Low-power 32-bit RISC-V processor		</a></li>
				<li><a href="//www.design-reuse.com/sip/40910/risc-v-processor-32-bit-5-stage-pipeline/"  title="View RISC-V processor  - 32 bit, 5-stage pipeline IP Description">  
		RISC-V processor  - 32 bit, 5-stage pipeline		</a></li>
				<li><a href="//www.design-reuse.com/sip/44087/compact-efficient-64-bit-risc-v-processor-with-5-stage-pipeline/"  title="View Compact, efficient 64-bit RISC-V processor with 5-stage pipeline IP Description">  
		Compact, efficient 64-bit RISC-V processor with 5-stage pipeline		</a></li>
				<li><a href="//www.design-reuse.com/sip/47863/linux-capable-64-bit-risc-v-processor-core-with-7-stage-pipeline/"  title="View Linux capable 64-bit RISC-V processor core with 7-stage pipeline IP Description">  
		Linux capable 64-bit RISC-V processor core with 7-stage pipeline		</a></li>
				<li><a href="//www.design-reuse.com/sip/48158/dual-thread-superscalar-embedded-32-bit-risc-v-core-with-9-stage-pipeline/"  title="View Dual thread, superscalar, embedded 32-bit RISC-V core with 9-stage pipeline IP Description">  
		Dual thread, superscalar, embedded 32-bit RISC-V core with 9-stage pipeline		</a></li>
				</ul></div>
		</div>
		<div class="spaceboy" style="clear:both"> </div>
		<div  class="txtR" >
		<a  class="fcTheme ud"   style="color:#E41129;" href="//www.design-reuse.com/sip?q=risc-v">See more RISC-V 
				 IP 
		 &gt;&gt;</a>
		</div>
		</div>
		

</div>
</div>
</div>
	<div id="right135">
	<!--sphider_noindex-->
	<ins data-revive-zoneid="5" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
	<br/><br/>
	<ins data-revive-zoneid="6" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
	<br/><br/>
	
<ins data-revive-zoneid="7" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
	<br/><br/>
		<!--/sphider_noindex-->
	</div>

<div class="clearBoth"></div>
<div id="leaderboard2015">
<ins data-revive-zoneid="3" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
</div> 

</div>


 <div class="clearLeft"></div> 
  </div>
  
  
<div id="bandeauBasFooter"><div id="bandeauBasFooter2">
    <div id="copyright">
	<!--sphider_noindex-->
	<p><strong>© 2020 Design And Reuse</strong></p> <p>All Rights Reserved.</p>
	<p style="font-weight: normal;">No portion of this site may be copied, retransmitted, reposted, duplicated or otherwise used without the express written permission of Design And Reuse.</p> 
	</div>
<!--
	<div class="colonne sansBordure">
    <h4 style="font-size: 16px;">Give us your feedback</h4>
	<p style="height:50px">Was this page helpful?<br/>Ask us a question or get help<br/><br/></p>
		<div class="sitebutton">
		<a href="/contact/" title="Talk to us" id="talktous"  rel="nofollow">Talk to us</a>					
        </div>
	</div>
	-->
                
	<div class="colonne sansBordure">
	<h4 style="font-size: 16px;">Partner with us</h4>
	<p style="height:50px">
	Visit our new Partnership Portal for more information.
	<br/><br/></p>
				<div class="sitebutton">
				<a href="https://www.design-reuse-embedded.com/join-dr/" id="talktous"  rel="nofollow">Partner with us</a>
				</div>
	</div>             
	
	<div class="colonne hid980">
	<h4 style="font-size: 16px;">List your Products</h4>
	<p style="height:50px">Suppliers, list
	your IPs for free.<br/><br/></p>
				<div class="sitebutton">
									<a href="/map/providers/" id="addproducts">List your Products</a>

						</div>
	</div>

	<div class="colonne">
	<h4 style="font-size: 16px;">Design-Reuse.com</h4>
	<ul>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/contact/">Contact Us</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/products/about.php">About us</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/partners/">D&amp;R Partner Program</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/ads/">Advertise with Us</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/privacy/">Privacy Policy</a></li>
	</ul>
	

	</div>


</div></div>



</section>


	<script type="application/javascript" src="https://static.designandreuse.com/staticdefault-20150421.js"></script>
	



<script type="text/javascript">
var pathurl = "https://www.design-reuse.com/sip/";
var thispageid= "";
var backurl= "%2Fsip%2Fsingle-issue-embedded-risc-v-core-with-4-stage-pipeline-ip-48159%2F";
</script> 


<script type="text/javascript">
$(document).ready(function() {
    $('ul#iplist li').mouseover(function(){
          $(this).find('div.data div.ipdetail').css('display','inline');
    });
    $('ul#iplist li').mouseout(function(){
          $(this).find('div.data div.ipdetail').css('display','none');
    });
});

</script> 
	<script type="text/javascript" src="https://static.designandreuse.com/jscript/jquery.qtip.min.js"></script>
	<script type="text/javascript" src="https://static.designandreuse.com/jscript/catalog12.js?5"></script>
	
			
	<script type="text/javascript">
	$(document).ready(function(){
		$("div#preview").delay(900).slideUp(400); 

	});
	</script>
			
<script type="text/javascript" src="https://static.designandreuse.com/jscript/anylinkcssmenu.js">
/***********************************************
* AnyLink CSS Menu script v2.0- © Dynamic Drive DHTML code library (www.dynamicdrive.com)
* This notice MUST stay intact for legal use
* Visit Project Page at http://www.dynamicdrive.com/dynamicindex1/anylinkcss.htm for full source code
***********************************************/
</script>
<script type="text/javascript">

$(document).ready(function () {
    $('#showrefine').click(function () {
    $('#left200').toggle('500');
    $('#showrefine').toggle();
    });    
    $('#closerefine').click(function () {
    $('#left200').toggle('500');
    $('#showrefine').toggle();
    });    
});
</script>




					<div id="flosensing"></div>
	<script type="text/javascript">
	$( "#flosensing" ).append( "<img src=\"//www.design-reuse.com/flosensing/lg.php?url=%2Fsip%2Fsingle-issue-embedded-risc-v-core-with-4-stage-pipeline-ip-48159%2F&c=sip&action=preview&prod=48159&prov=1283&ref=\" width=\"1\" height=\"1\">");

	</script>
			
		
	

<script async src="//www.us.design-reuse.com/adserver/www/delivery/asyncjs.php"></script>
</body>
</html>