<!DOCTYPE html>
<html lang="en">
<head>
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=no" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
<title>SM4-XTS Multi-Booster IP Core</title>
<meta http-equiv="Cache-Control" content="no-cache"/>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8"/>
<link rel="shortcut icon" href="//static.designandreuse.com/IMAGES/favicon.ico" />
<link rel="alternate" type="application/rss+xml" title="All D and R Feeds" href="https://www.design-reuse.com/xml/1/1/all/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Headline News" href="https://www.design-reuse.com/xml/1/1/news/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Industry Articles" href="https://www.design-reuse.com/xml/1/1/articles/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R New Products" href="https://www.design-reuse.com/xml/1/1/products/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Wanted IPs" href="https://www.design-reuse.com/xml/1/1/wanted/rss.xml"/>
<link rel="alternate" type="application/rss+xml" title="D and R Industry Expert Blogs" href="https://www.design-reuse.com/xml/1/1/blogs/rss.xml"/>
<meta name="description" content="The SM4-XTS Multi-Booster crypto engine includes a generic &amp; scalable implementation of the SM4 algorithm (a block cipher specified by the OSCCA) making ..."/>
<meta name="keywords" content="sm4, xts, multi-booster, sm4-xts multi-booster, ba425, ip core, silicon ip, semiconductor ip"/>
<!--sphider_noindex--> 
<meta http-equiv="Pragma" content="no-cache"/>
<meta name="Expires" content="Fri, 01 Jan 1990 00:00:00 GMT"/>
<meta name="robots" content="noarchive"/><!--[if lte IE 8]>
<script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>

<script src="https://www.design-reuse.com//jscript/respond.min.js"></script>
<![endif]-->
	<link rel="stylesheet" type="text/css" href="https://static.designandreuse.com/staticcatalog-20200213.css"/>

</head>
<body>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-118253-2', 'auto');
  ga('send', 'pageview');

</script>
<form>
<input id="menu-toggle" class="menu-toggle" type="checkbox">
<nav>
	<div class="menu">
	<ul>
		<li><a href="https://www.design-reuse.com/">Home</a></li>
		<li><a href="https://www.design-reuse.com/sip/">Search Silicon IP</a></li>
		<li><a href="https://www.design-reuse.com/vip/">Search Verification IP</a></li>
		<li><a href="https://www.design-reuse.com/news/">Latest News</a></li>
		<li><a href="https://www.design-reuse.com/articles/">Industry Articles</a></li>
		<li><a href="https://www.design-reuse.com/industryexpertblogs/">Industry Expert Blogs</a></li>
		<li><a href="https://www.design-reuse.com/video/">Videos</a></li>
		<li><a href="https://www.design-reuse.com/slides/">Slides</a></li>
		<li><a href="https://www.design-reuse.com/ipsoc2018/">Events</a></li>
 
	</ul>
  </div> 
</nav>
<section id="contentfull">
<div class="top-bar">
  <label for="menu-toggle" id="toggle">&equiv; <span>Menu</span></label> 
  
  <a id="drlogoS" href="https://www.design-reuse.com/">Design And Reuse</a>

<ul id="top-bar-subscribe" style="margin-right:15px; margin-top:5px">

			<li class="d-inline" >
		<a class="login c7 sz11" href="https://www.design-reuse.com/login2.php?nexturl=https%3A%2F%2Fwww.design-reuse.com%2Fsip%2Fsm4-xts-multi-booster-ip-47832%2F">Login</a>
		</li>
		<li class="c5 sz11 d-inline">|</li>
		

	<li id="nav-login167156" class="d-inline">
	<a class="login c7 sz11" href="https://www.design-reuse.com/users/signup.php">Subscribe</a>
	</li>


</ul>
  </div> 
</form>
<div id="bandeau-nav167156">
<div class="list grid-980">

<ul id="nav-right167156" class="nav-right">


<li class="d-inline">
<a class="c7 sz11" href="https://www.design-reuse.com/about/">Company</a>
</li>
<li class="c5 sz11 d-inline">|</li>

<li class="d-inline">
<a class="c7 sz11" href="https://www.design-reuse.com/foundry/siliconip/cn.php">D&amp;R China</a>
</li>
<li class="c5 sz11 d-inline">|</li>
<li class="d-inline">
<a class="c7 sz11" href="https://www.design-reuse.com/foundry/siliconip/drembedded3.php" rel="nofollow">dr-embedded.com</a>
</li>

<li class="c5 sz11 d-inline">|</li>
<li class="d-inline">
<a class="c7 sz11" href="http://www.design-reuse-enterprise.com/" rel="nofollow">D&amp;R Products</a>
</li>
<li class="c5 sz11 d-inline">|</li>
 
<li class="d-inline dropdown">
<span class="c7 sz11" ><img src="https://static.designandreuse.com/img16/cn.png" width="21" height="16" style="margin-top:4px; margin-right:10px"></span>
  <div class="dropdown-content">
    <a href="https://www.design-reuse.com/" class="c5 sz11 d-inline"> <img src="https://static.designandreuse.com/img16/en.png" width="16" height="12" style="margin-top:4px;"> English</a>
    <a href="https://www.design-reuse.com/foundry/siliconip/cn.php" class="c5 sz11 d-inline"><img src="https://static.designandreuse.com/img16/cn.png" width="16" height="12" style="margin-top:4px"> Chinese</a>
  </div>
</li>

 
<style>
.dropdown {
    position: relative;
    display: inline-block;
	cursor: pointer;
}

.dropdown-content {
    display: none;
    position: absolute;
    background-color: white;
    min-width: 80px;
    box-shadow: 0px 8px 16px 0px rgba(0,0,0,0.2);
    padding: 2px;
	z-index: 99999;
	margin-top: -8px;
}

.dropdown:hover .dropdown-content {
    display: block;
}

.dropdown-content a {
    color: black;
    padding: 1px;
    text-decoration: none;
    display: block;
}
.dropdown-content a:hover {background-color: #f1f1f1}
</style>
			<li class="d-inline" >
		<a class="login c7 sz11" href="https://www.design-reuse.com/login2.php?nexturl=https%3A%2F%2Fwww.design-reuse.com%2Fsip%2Fsm4-xts-multi-booster-ip-47832%2F">Login</a>
		</li>
		<li class="c5 sz11 d-inline">|</li>
		

	<li id="nav-login167156" class="d-inline">
	<a class="login c7 sz11" href="https://www.design-reuse.com/users/signup.php">Subscribe to D&amp;R SoC News Alert</a>
	</li>


</ul>
</div>
</div>
<div id="leadeboard"><div id="leadeboard-in" >
	<a href="https://www.design-reuse.com/" id="drlogo">Design And Reuse</a>
	
</div></div> 
<div id="center">
    <div class="outter"></div>
    <div id="mainmenu" class="navigation navigation2012">
        <ul id="menu-bar">
            <li id="nav_onglet_1" class=" actu">
                <a href="https://www.design-reuse.com/sip/" class="imaged"><span class="text">Search IP</span><span class="drop"></span></a>
				<ul class="ombrage">
				
                    <li class="first">
					     <span>Categories</span>
                        <div class="ul">
                            <ul>
                                <li class="first"><a href="https://www.design-reuse.com/sip/"><strong>Silicon IP</strong></a></li>
                                <li><a href="https://www.design-reuse.com/sip/analog-mixed-signal-c-3/">Analog & Mixed Signal</a></li>
                                <li><a href="https://www.design-reuse.com/sip/storage-controller-phy-c-5/">Storage Controller &amp; PHY</a></li>
                                <li><a href="https://www.design-reuse.com/sip/graphic-peripheral-c-6/">Graphic &amp; Peripheral</a></li>
                                <li><a href="https://www.design-reuse.com/sip/interfaces-c-7/">Interface Controller &amp; PHY</a></li>
                                <li><a href="https://www.design-reuse.com/sip/processors-microcontrollers-c-9/">Processors &amp; Microcontrollers</a></li>
                                <li><a href="https://www.design-reuse.com/sip/memory-logic-library-c-10/">Memory &amp; Logic Library</a></li>
                                <li><a href="https://www.design-reuse.com/sip/security-c-11/">Security</a></li>
                                <li><a href="https://www.design-reuse.com/sip/multimedia-c-12/">Multimedia</a></li>
                                <li><a href="https://www.design-reuse.com/sip/wireline-communication-c-13/">Wireline Communication</a></li>
                                <li><a href="https://www.design-reuse.com/sip/wireless-communication-c-14/">Wireless Communication</a></li>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/sip/provider.php"><strong>Silicon IP Vendors</strong></a>
                                </li>



								
                            </ul>
                        </div>
                    </li>

					
                   <li>
						<span>&nbsp;</span>

                        <div class="ul">
							<ul>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/vip/"><strong>Verification IP</strong></a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/vip/">Search / Browse</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/vip/provider.php">Verification IP Vendors</a>
                                </li>

	
					
									<li class="first">
                                    <a href="https://www.design-reuse.com/hds/"><strong>Software IP</strong></a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/hds/">Search / Browse</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/hds/provider.php">Software IP Vendors</a>
                                </li>
   	  		
                         
                                <li>
                                    <strong>&nbsp;</strong>
                                </li>
                                <li style="border-top:0px">
                                    <strong>&nbsp;</strong>
                                </li>
                                <li>
                                    <strong>Additional Services</strong>
                                </li>
													
	                                <li>
                                    <a href="https://www.design-reuse.com/sip/wanted/">Wanted IPs</a>
                                </li>
   	  	
                                <li>
                                    <a href="https://www.design-reuse.com/ipanalytics/">IP Analytics</a>
                                </li>
                            </ul>
                        </div>
                    </li>
					
					<li>
						<a href="https://www.design-reuse.com/sip/">	
						Featured Products</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="https://www.design-reuse.com/sip/high-performance-embedded-host-nvme-ip-42437/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/ipmaker.gif" alt="IP-Maker" height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/high-performance-embedded-host-nvme-ip-42437/">High Performance Embedded Host NVMe</a></p></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/sip/philips-sja1000-compatible-can-core-ip-45612/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/cobhamgaisler.gif" alt="Cobham Gaisler" height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/philips-sja1000-compatible-can-core-ip-45612/">Philips SJA1000 compatible CAN core </a></p></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/sip/16-bit-16ksps-sd-adc-ip-44613/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/leolsi.gif" alt="LeoLSI" height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/16-bit-16ksps-sd-adc-ip-44613/">16-Bit, 16kSPS SD ADC</a></p></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/sip/sensor-fusion-solutions-for-augmented-and-virtual-reality-robotics-motion-controllers-and-iot-ip-47198/"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="https://static.designandreuse.com/sip/logo/ceva.gif?3" alt="CEVA, Inc." height="27" width="64" class="logo deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/sip/sensor-fusion-solutions-for-augmented-and-virtual-reality-robotics-motion-controllers-and-iot-ip-47198/">Sensor fusion solutions for augmented and virtual reality, robotics, motion controllers, and IoT</a></p></div></li>	     
						</ul></div>
						
                    </li>

                </ul>
				
            </li>
  		

	
					
	
            <li id="nav_onglet_3" class=" actu">
                <a href="https://www.design-reuse.com/news/" class="imaged"><span class="text">News</span><span class="drop"></span></a>
              <ul>
                    <li class="first">
                        <span>Categories</span>
                        <div class="ul">
                            <ul>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/news/semiconductor-ip-soc-0.html">IP/SoC Products </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/embedded-systems-0.html">Embedded Systems </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/foundries-0.html">Foundries</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/fpga-0.html">FPGA </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/fabless-0.html">Fabless / IDM </a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/deals-0.html">Deals</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/legal-0.html">Legal</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/business-0.html">Business</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/financial-0.html">Financial Results</a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/news/people-0.html">People</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/news/commentary-analysis-0.html">Commentary / Analysis</a>
                                </li> 
								<li>
                                    <a href="https://www.design-reuse.com/news/mostpopular"><strong>20 Most Popular News</strong></a>
                                </li>
                            </ul>
                        </div>
                    </li>
					<li>
                        <a href="https://www.design-reuse.com/news/">					
						Latest News</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="//www.design-reuse.com/news/47765/silex-insight-chinese-oscca-400-gbps-sm4-crypto-core.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news47765/silex.jpg"  alt="silex-insight-chinese-oscca-400-gbps-sm4-crypto-core" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="//www.design-reuse.com/news/47765/silex-insight-chinese-oscca-400-gbps-sm4-crypto-core.html">Silex Insight launches Chinese OSCCA high performance (400 Gbps) SM4 Crypto Core</a></p><div class="meta">Thursday Apr. 02, 2020</div></div></li>	<li><div class="media"><a href="//www.design-reuse.com/news/47763/intel-2019-semiconductor-market.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news47763/intel5.jpg"  alt="intel-2019-semiconductor-market" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="//www.design-reuse.com/news/47763/intel-2019-semiconductor-market.html">Intel shines amidst the carnage of the 2019 semiconductor market</a></p><div class="meta">Wednesday Apr. 01, 2020</div></div></li>	<li><div class="media"><a href="//www.design-reuse.com/news/47761/hardent-maojet-fujisoft-asia.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news47761/hardent.jpg"  alt="hardent-maojet-fujisoft-asia" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="//www.design-reuse.com/news/47761/hardent-maojet-fujisoft-asia.html">Hardent Joins Forces with Maojet &amp; Fujisoft To Expand Presence in Asia</a></p><div class="meta">Wednesday Apr. 01, 2020</div></div></li>	     
						</ul></div>

						
                    </li>
                </ul>

            </li>
            <li id="nav_onglet_4" class=" actu">
                <a href="https://www.design-reuse.com/articles/" class="imaged"><span class="text">Industry Articles</span><span class="drop"></span></a>
              <ul>
                    <li class="first">
                        <span>Categories</span>
                        <div class="ul">
                            <ul>
                                <li class="first">
                                    <a href="https://www.design-reuse.com/articles/semiconductor-ip-soc-0.html">IP/SoC Products </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/articles/embedded-systems-0.html">Embedded Systems </a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/articles/foundries-0.html">Foundries</a>
                                </li>
                                <li>
                                    <a href="https://www.design-reuse.com/articles/fpga-0.html">FPGA </a>
                                </li>
                               <li>
                                    <a href="https://www.design-reuse.com/articles/business-0.html">Business</a>
                                </li>
								<li>
                                    <a href="https://www.design-reuse.com/articles/mostpopular"><strong>20 Most Popular Articles</strong></a>
                                </li>
                            </ul>
                        </div>
                    </li>
					<li>
                        <a href="https://www.design-reuse.com/articles/">					
						Featured Articles</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="https://www.design-reuse.com/articles/47750/neopuf-quantum-tunneling-puf.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news47750/puf2.jpg"  alt="neopuf-quantum-tunneling-puf" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/articles/47750/neopuf-quantum-tunneling-puf.html">NeoPUF, A Reliable and Non-traceable Quantum Tunneling PUF</a></p><div class="meta">Monday Mar. 30, 2020</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/articles/47717/understanding-physical-unclonable-function-puf.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news47717/invia.jpg"  alt="understanding-physical-unclonable-function-puf" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/articles/47717/understanding-physical-unclonable-function-puf.html">Understanding Physical Unclonable Function (PUF)</a></p><div class="meta">Monday Mar. 23, 2020</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/articles/47692/shift-power-reduction-methods-and-effectiveness-for-testability-in-asic.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/news_img2/news47692/einfo2.jpg"  alt="shift-power-reduction-methods-and-effectiveness-for-testability-in-asic" width="73" height="50" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/articles/47692/shift-power-reduction-methods-and-effectiveness-for-testability-in-asic.html">Shift Power Reduction Methods and Effectiveness for Testability in ASIC</a></p><div class="meta">Monday Mar. 16, 2020</div></div></li>	     
						</ul></div>

						
                    </li>
                </ul> 
            </li>
            <li id="nav_onglet_5" class=" actu">
                <a href="https://www.design-reuse.com/industryexpertblogs/" class="imaged"><span class="text">Blogs</span><span class="drop"></span></a>
               <ul>
 					<li>
                        <a href="https://www.design-reuse.com/industryexpertblogs/">					
						Industry Expert Blogs</a> 
						<div class="ul articles">	
						<ul>
						<li><div class="media"><a href="https://www.design-reuse.com/industryexpertblogs/47764/post-quantum-crypto-and-rambus.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/industryexpertblogs/images/rambus.gif"  alt="post-quantum-crypto-and-rambus" width="64" height="64" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/industryexpertblogs/47764/post-quantum-crypto-and-rambus.html">Post-Quantum Crypto and Rambus</a></p><div class="meta">Rambus Blog - Rambus</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/industryexpertblogs/47759/key-applications-for-in-chip-monitoring-thermal-sensing.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/industryexpertblogs/images/moortec.gif"  alt="key-applications-for-in-chip-monitoring-thermal-sensing" width="64" height="64" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/industryexpertblogs/47759/key-applications-for-in-chip-monitoring-thermal-sensing.html">Key Applications for In Chip Monitoring... Thermal Sensing</a></p><div class="meta">Moortec Blog - By Richard McPartland, Moortec</div></div></li>	<li><div class="media"><a href="https://www.design-reuse.com/industryexpertblogs/47751/vehicle-cybersecurity-a-vital-never-ending-journey.html"><img src="//static.designandreuse.com/img11/ajax-loader2.gif" longdesc="//static.designandreuse.com/industryexpertblogs/images/ultrasoc.jpg"  alt="vehicle-cybersecurity-a-vital-never-ending-journey" width="64" height="64" class="deferredload"/></a></div><div class="article product"><p><a href="https://www.design-reuse.com/industryexpertblogs/47751/vehicle-cybersecurity-a-vital-never-ending-journey.html">Vehicle cybersecurity: a vital never ending journey</a></p><div class="meta">UltraSoC  Blog - Aileen Ryan, UltraSoC</div></div></li>	     
						</ul></div>

						
                    </li>
                </ul>     
            </li>
            <li id="nav_onglet_6" class=" cols">
                <a href="https://www.design-reuse.com/video/" class="imaged nodrop"><span class="text">Videos</span></a>

            </li>
            <li id="nav_onglet_8" class=" cols">
                <a href="https://www.design-reuse.com/slides/" class="imaged nodrop"><span class="text">Slides</span></a>

            </li>

            <li id="nav_onglet_7" class=" cols">

					<a  rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2020/" class="imaged"><span class="text">Events</span><span class="drop"></span></a>
					<ul>
                    <li class="first">
					
					  <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2020/">IP-SOC  2020</a>

					<!--<span>Archives</span>-->
                        <div class="ul">
                            <ul>

								<li class="first">
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2019/">IP-SoC Days 2019</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2018/">IP-SoC Days 2018</a>
                                </li>
								<li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/">IP-SoC Days 2017</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2019/grenoble2019/">IP-SoC 2019</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsocdays2018/grenoble2018/program.jsp">IP-SoC 2018</a>
                                </li>
                                <li>
                                    <a rel="nofollow" href="https://www.design-reuse-embedded.com/ipsocdays/ipsoc2017/postEvent.jsp">IP-SoC 2017</a>
                                </li>
                          


                            </ul>
                        </div>
                    </li>

                </ul>
            </li>
 
        </ul>
		
<div id="search">
		<form method="get" action="https://www.design-reuse.com/search/"  style="top:0px; width:250px">
<ul id="searchFilter"><li class="filterBtn" onclick="return true" title="search filter">
<div class="searchDropdown">
<fieldset>
<legend>Choose a filter </legend>
<ul id="searchOptions">
<li><input id="areafull" type="radio" value="full" name="area"/><label for="areafull">Full Site Search</label></li>
<li><input id="areasip" type="radio" value="sip" checked="checked" name="area"/><label for="areasip">Silicon IP</label></li>
<li><input id="areavip" type="radio" value="vip" name="area"/><label for="areavip">Verification IP</label></li>
<li><input id="areahds" type="radio" value="hds" name="area"/><label for="areahds">Software IP</label></li>
<li><input id="areanews" type="radio" value="news" name="area"/><label for="areanews">News</label></li>
<li><input id="areaarticle" type="radio" value="articles" name="area"/><label for="areaarticle">Industry Articles</label></li>
</ul>
</fieldset>
</div>
</li>
</ul>
<input id="i" name="i" class="inset " type="text" maxlength="255" value="Search Silicon IP"/>
<input class="magBtn" type="submit" value="Search D&amp;R site" title="search"/>
</form></div>

    </div>
</div>


<div id="section">
<div id="global" class="viewip">


<!--/sphider_noindex--> 

<div id="content">


<div id="left800" class="bluelink">

	<span style="font-size: 11px; font-weight: bold;">You are here:</span>  
	<ul class="path">
	<li><a href="/sip/">Silicon IP Catalog</a></li> &gt; <li><a href='/sip/security-c-11/'> Security </a></li> &gt; <li><a href='/sip/cryptography-cores-c-45/'> Cryptography Cores </a></li> &gt; <li><a href='/sip/other-c-223/'> Other </a></li>	</ul><br/><br/>
		
	

	<h1  style="margin: 0px; padding:0px;">

	
	SM4-XTS Multi-Booster 	
	
	</h1>


	<div id="wrapleft500"  class=" clearfix" >

	<div id="left500" class="bluelink " >
	<div id="preview">

		<div style="margin-top:10px; margin-bottom:10px">
	The SM4-XTS Multi-Booster crypto engine includes a generic & scalable implementation of the SM4 algorithm (a block cipher specified by the OSCCA) making the solution ideal for high-end applications (including key, tweak, input and output registers and Galois field multiplier). <br/> <br/>This crypto engine targets high-performance applications such as data storage and memory encryption. Thanks to its scalability, it can be tailored to reach the best trade-off between performances, area and technology. <br/> <br/>Overview <br/>The SM4-XTS crypto engine is easily portable to ASIC and FPGA. It supports a wide range of applications on various technologies. The unique architecture enables a high level of flexibility. The throughput and features required by a specific application can be taken into account in order to select the most optimal and compact configuration. <br/> <br/>For other XTS Multi-Booster solutions, please see dedicated product sheet: AES-XTS Multi-Booster (BA416). We also offer a multi-purpose SM4 Crypto Engine (BA419)</div> 
				<h2 class="ipdescription">Features</h2>
			<ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">ASIC and FPGA</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">High throughput:</span></li><ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">  ASIC: &gt;400 Gbps</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">  FPGA: 100 Gbps/s</span></li></ul><li style="padding-bottom: 3px;"><span style="color:#333333">Scalable solution</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Can be provided with AXI DMA & software</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Masking option available with excellent protection against SPA & DPA</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Cipher stealing (optional)</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Low power feature</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Straight forward integration with simple FIFO interfaces</span></li></ul> 
			<h2 class="ipdescription">Benefits</h2>


		 <ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">Off-the-shelf, predictable and silicon-proven solution</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Easy-to-Integrate</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Unrivaled speed performance</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Logic footprint optimized to performance requirements and used functionalities  </span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Scalable Multi-Core solution enabling best trade-off between area and performance</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Portable and optimized to ASIC or FPGA technology</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Upgradeable to new performance requirements or to new generations of ASIC or FPGA technology</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">User-friendly Software API</span></li></ul> 
		
		<h2 class="ipdescription">Deliverables</h2>
	<ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">Netlist or RTL </span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Scripts for synthesis </span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Self-checking TestBench based on FIPS vectors</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Datasheet</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">Integration guide</span></li></ul> 
		<h2 class="ipdescription">Applications</h2>
	<ul style="list-style-type: square; margin: 7px 0 12px 24px; padding: 0; color: rgb(204, 0, 0);"><li style="padding-bottom: 3px;"><span style="color:#333333">Encrypted Disk/Data storage</span></li><li style="padding-bottom: 3px;"><span style="color:#333333">External memory encryption</span></li></ul> 
		
<h2 class="ipdescription">Block Diagram of the SM4-XTS Multi-Booster IP Core</h2>	<img src="//www.design-reuse.com/sip/blockdiagram/47832/20200402095523-main-SM4-XTS-Multi-Booster-Diagram.jpg" width="480" height="293" alt="SM4-XTS Multi-Booster Block Diagam">
	<br/><br/>	    

	

<br/><br/>

<hr/>
</div>


	<h2 style="font-weight:normal; font-size: 14px;">
	View	
	  <b>SM4-XTS Multi-Booster</b> 
	  	full description to...
	</h2>
	<div style="float: left; width:270px">
	<ul><li>
	see the entire
	 <b>SM4-XTS Multi-Booster</b> 
	datasheet		
		
	</li>
	<li> 
	get in contact with 
	  <b>SM4-XTS Multi-Booster</b>  
	Supplier	
	</li>
	</ul>
	</div>
	<div style="float: left; width:185px; margin-top:20px">

	<style type="text/css">
	.btn-more-2, .hd li.on em, div.hd li.sparkle a, .hd, #mastheadbd .top, #mastheadbd, #doors li a, #today .ft li.on a{
	background-image:url(//www.us.design-reuse.com/img06/grd-1px_1.1.gif);
	background-repeat:repeat-x;
	}



	.btn-more-2{
	padding:1px 10px 2px;
	*padding:1px 5px 0;
	font:bold 100% arial;
	color:#000;
	cursor:pointer;
	width:180px;
	white-space:nowrap;
	border:1px solid #999b9a;
	background-color:#ce9200;
	background-position:0 -450px;
	cursor: pointer
	}


	</style>

	
	<form action="//www.design-reuse.com/users/join.php" name="contactprovider" method="get">
	<input type="hidden" name="productid" value="47832"/> 
	<input type="hidden" name="target" value="sip"/> 
	<input type="hidden" name="nexturl" value="https://www.design-reuse.com/sip/sm4-xts-multi-booster-ip-47832/"/> 
	<input type="submit" class="btn-more-2" value="View Full Description"/><br/><br/>
	</form>
	
		

</div>
</div>
</div>
<div id="middle300" class="bluelink">
		<div class="bloc300 gradient">
		<h2 class="oswald"  style="margin-bottom: 15px;margin-top: 0px;">
		 SM4 
		 IP 
		 
		</h2>
			<div><div class="type1">
			<ul class="arrowList1" style="line-height: 13px; height: auto; border-bottom: 0px; padding: 0">
			
				<li><a href="//www.design-reuse.com/sip/44834/inside-secure-sm4-engine/"  title="View INSIDE Secure SM4 Engine IP Description">  
		INSIDE Secure SM4 Engine		</a></li>
				<li><a href="//www.design-reuse.com/sip/47443/inside-secure-sm4-xts-engine/"  title="View INSIDE Secure SM4-XTS engine IP Description">  
		INSIDE Secure SM4-XTS engine		</a></li>
				<li><a href="//www.design-reuse.com/sip/44693/sm4-crypto-engine/"  title="View SM4 Crypto Engine  IP Description">  
		SM4 Crypto Engine 		</a></li>
				<li><a href="//www.design-reuse.com/sip/47274/crypto-coprocessor/"  title="View Crypto Coprocessor  IP Description">  
		Crypto Coprocessor 		</a></li>
				</ul></div>
		</div>
		<div class="spaceboy" style="clear:both"> </div>
		<div  class="txtR" >
		<a  class="fcTheme ud"   style="color:#E41129;" href="//www.design-reuse.com/sip?q=sm4">See more SM4 
				 IP 
		 &gt;&gt;</a>
		</div>
		</div>
		

</div>
</div>
</div>
	<div id="right135">
	<!--sphider_noindex-->
	<ins data-revive-zoneid="5" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
	<br/><br/>
	<ins data-revive-zoneid="6" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
	<br/><br/>
	
<ins data-revive-zoneid="7" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
	<br/><br/>
		<!--/sphider_noindex-->
	</div>

<div class="clearBoth"></div>
<div id="leaderboard2015">
<ins data-revive-zoneid="3" data-revive-id="29233ba5e5eaab276b45ed91c198a0f2"></ins>
</div> 

</div>


 <div class="clearLeft"></div> 
  </div>
  
  
<div id="bandeauBasFooter"><div id="bandeauBasFooter2">
    <div id="copyright">
	<!--sphider_noindex-->
	<p><strong>© 2020 Design And Reuse</strong></p> <p>All Rights Reserved.</p>
	<p style="font-weight: normal;">No portion of this site may be copied, retransmitted, reposted, duplicated or otherwise used without the express written permission of Design And Reuse.</p> 
	</div>
<!--
	<div class="colonne sansBordure">
    <h4 style="font-size: 16px;">Give us your feedback</h4>
	<p style="height:50px">Was this page helpful?<br/>Ask us a question or get help<br/><br/></p>
		<div class="sitebutton">
		<a href="/contact/" title="Talk to us" id="talktous"  rel="nofollow">Talk to us</a>					
        </div>
	</div>
	-->
                
	<div class="colonne sansBordure">
	<h4 style="font-size: 16px;">Partner with us</h4>
	<p style="height:50px">
	Visit our new Partnership Portal for more information.
	<br/><br/></p>
				<div class="sitebutton">
				<a href="https://www.design-reuse-embedded.com/join-dr/" id="talktous"  rel="nofollow">Partner with us</a>
				</div>
	</div>             
	
	<div class="colonne hid980">
	<h4 style="font-size: 16px;">List your Products</h4>
	<p style="height:50px">Suppliers, list
	your IPs for free.<br/><br/></p>
				<div class="sitebutton">
									<a href="/map/providers/" id="addproducts">List your Products</a>

						</div>
	</div>

	<div class="colonne">
	<h4 style="font-size: 16px;">Design-Reuse.com</h4>
	<ul>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/contact/">Contact Us</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/products/about.php">About us</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/partners/">D&amp;R Partner Program</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/ads/">Advertise with Us</a></li>
	<li class="puceBlancheMini"><a href="https://www.design-reuse.com/privacy/">Privacy Policy</a></li>
	</ul>
	

	</div>


</div></div>



</section>


	<script type="application/javascript" src="https://static.designandreuse.com/staticdefault-20150421.js"></script>
	



<script type="text/javascript">
var pathurl = "https://www.design-reuse.com/sip/";
var thispageid= "";
var backurl= "%2Fsip%2Fsm4-xts-multi-booster-ip-47832%2F";
</script> 


<script type="text/javascript">
$(document).ready(function() {
    $('ul#iplist li').mouseover(function(){
          $(this).find('div.data div.ipdetail').css('display','inline');
    });
    $('ul#iplist li').mouseout(function(){
          $(this).find('div.data div.ipdetail').css('display','none');
    });
});

</script> 
	<script type="text/javascript" src="https://static.designandreuse.com/jscript/jquery.qtip.min.js"></script>
	<script type="text/javascript" src="https://static.designandreuse.com/jscript/catalog12.js?5"></script>
	
			
	<script type="text/javascript">
	$(document).ready(function(){
		$("div#preview").delay(900).slideUp(400); 

	});
	</script>
			
<script type="text/javascript" src="https://static.designandreuse.com/jscript/anylinkcssmenu.js">
/***********************************************
* AnyLink CSS Menu script v2.0- © Dynamic Drive DHTML code library (www.dynamicdrive.com)
* This notice MUST stay intact for legal use
* Visit Project Page at http://www.dynamicdrive.com/dynamicindex1/anylinkcss.htm for full source code
***********************************************/
</script>
<script type="text/javascript">

$(document).ready(function () {
    $('#showrefine').click(function () {
    $('#left200').toggle('500');
    $('#showrefine').toggle();
    });    
    $('#closerefine').click(function () {
    $('#left200').toggle('500');
    $('#showrefine').toggle();
    });    
});
</script>




					<div id="flosensing"></div>
	<script type="text/javascript">
	$( "#flosensing" ).append( "<img src=\"//www.design-reuse.com/flosensing/lg.php?url=%2Fsip%2Fsm4-xts-multi-booster-ip-47832%2F&c=sip&action=preview&prod=47832&prov=140&ref=\" width=\"1\" height=\"1\">");

	</script>
			
		
	

<script async src="//www.us.design-reuse.com/adserver/www/delivery/asyncjs.php"></script>
</body>
</html>